+ (add) (AutoLISP)

Returns the sum of all numbers

Supported Platforms: Windows and Mac OS

Signature

(+ [number number ...])
number

Type: Integer or Real

A numeric value.

Return Values

Type: Integer or Real

The result of the addition. If you supply only one number argument, this function returns the result of adding it to zero. If you supply no arguments, the function returns 0.

Examples

(+ 1 2)
3

(+ 1 2 3 4.5)
10.5

(+ 1 2 3 4.0)
10.0