The following pseudo-code shows the logic behind the main function, gp:RedefinePolyBorder:
Function gp:RedefinePolyBorder Extract the previous polyline corner points (12, 13, 14, and 15 key values). Find the moved corner point by comparing the previous polyline corner points with the current corner points. (The one "misfit" point will be the point that moved.) Set the new corner points by recalculating the two points adjacent to the moved point. Update the new corner points in the reactor data (that will be stored back in the reactor for the modified polyline). Update other information in the reactor data. (Start point, endpoint, width, and length of path need to be recalculated.) End Function