The following table identifies the commands in the Revit Platform UI Manage tab, and corresponding APIs.
Table 7: Settings in API and UI
UI command | Associated API | Reference |
Settings Project Information | Document.ProjectInformation | See the following note |
Settings Project Parameters | Document.ParameterBindings (Only for Shared Parameter) | See Shared Parameters |
Project Location panel | Document.ProjectLocations Document.ActiveProjectLocation | See Place and Locations |
Settings Additional Settings Fill Patterns | FilteredElementCollector filtering on class FillPatternElement | See the following note |
Settings Materials | FilteredElementCollector filtering on class Material | See Material Management |
Settings Object Styles | Document.Settings.Categories | See the following note |
Phasing Phases | Document.Phases | See the following note |
Settings Structural Settings | Loads and related structural settings are available in the API | See Structural Engineering |
Settings Project Units | Document.GetUnits() | See Units |
Area and Volume Calculations (on the Room & Area panel) | AreaVolumeSettings.GetAreaVolumeSettings() | See the following note |
Table 8: ProjectInformation
Parameters | Corresponding API | Built-in Parameters |
Project Issue Date | ProjectInfo.IssueDate | PROJECT_ISSUE_DATE |
Project Status | ProjectInfo.Status | PROJECT_STATUS |
Client Name | ProjectInfo.ClientName | CLIENT_NAME |
Project Address | ProjectInfo.Address | PROJECT_ADDRESS |
Project Name | ProjectInfo.Name | PROJECT_NAME |
Project Number | ProjectInfo.Number | PROJECT_NUMBER |
Fill Patterns - Retrieve all Fill Patterns in the current document using a FilteredElementCollector filtering on class FillPatternElement. Specific FillPatterns can be retrieved using the static methods FillPatternElement.GetFillPattern(Document, ElementId) or FillPatternElement.GetFillPatternByName (Document, string).