Specifies whether the hatch is associative.
Supported platforms: Windows only
Read-only: Yes
Type: Boolean
An associative hatch is updated when its boundaries are modified. A nonassociative hatch is not updated when its boundaries are modified.
Associativity can only be set when a hatch is created. See the AddHatch method for more information on creating a hatch.
VBA:
Sub Example_AssociativeHatch() ' This example creates a hatch in model space. ' It then reports whether the hatch is associative. Dim hatchObj As AcadHatch Dim patternName As String Dim PatternType As Long Dim bAssociativity As Boolean ' Define the hatch patternName = "ANSI31" PatternType = 0 bAssociativity = True ' Create the associative Hatch object Set hatchObj = ThisDrawing.ModelSpace.AddHatch(PatternType, patternName, bAssociativity) ' Create the outer loop for the hatch. ' An arc and a line are used to create a closed loop. Dim outerLoop(0 To 1) As AcadEntity Dim center(0 To 2) As Double Dim radius As Double Dim startAngle As Double Dim endAngle As Double center(0) = 5: center(1) = 3: center(2) = 0 radius = 3 startAngle = 0 endAngle = 3.141592 Set outerLoop(0) = ThisDrawing.ModelSpace.AddArc(center, radius, startAngle, endAngle) Set outerLoop(1) = ThisDrawing.ModelSpace.AddLine(outerLoop(0).startPoint, outerLoop(0).endPoint) ' Append the outer loop to the hatch object hatchObj.AppendOuterLoop (outerLoop) ' Evaluate and display the hatch hatchObj.Evaluate ThisDrawing.Regen True ' Return whether the hatch is associative. Dim hatchAssoc As Boolean hatchAssoc = hatchObj.AssociativeHatch MsgBox "The HatchStyle is " & IIf(hatchObj.AssociativeHatch, "associative.", "not associative."), , "AssociativeHatch Example" End Sub
Visual LISP:
(vl-load-com) (defun c:Example_AssociativeHatch() ;; This example creates a hatch in model space. ;; It then reports whether the hatch is associative. (setq acadObj (vlax-get-acad-object)) (setq doc (vla-get-ActiveDocument acadObj)) ;; Define the hatch (setq patternName "ANSI31" patternType 0 bAssociativity :vlax-true) ;; Create the associative Hatch object (setq modelSpace (vla-get-ModelSpace doc)) (setq hatchObj (vla-AddHatch modelSpace patternType patternName bAssociativity acHatchObject)) ;; Create the outer loop for the hatch. ;; An arc and a line are used to create a closed loop. (setq center (vlax-3d-point 5 3 0) radius 3 startAngle 0 endAngle 3.141592) (setq arc (vla-AddArc modelSpace center radius startAngle endAngle)) (setq line (vla-AddLine modelSpace (vla-get-StartPoint arc) (vla-get-EndPoint arc))) (setq outerLoop (vlax-make-safearray vlax-vbObject '(0 . 1))) (vlax-safearray-put-element outerLoop 0 arc) (vlax-safearray-put-element outerLoop 1 line) ;; Append the outer loop to the hatch object (vla-AppendOuterLoop hatchObj outerLoop) ;; Evaluate and display the hatch (vla-Evaluate hatchObj) (vla-Regen doc :vlax-true) ;; Return whether the hatch is associative. (setq hatchAssoc (vla-get-AssociativeHatch hatchObj)) (alert (strcat "The HatchStyle is " (if (= hatchAssoc :vlax-true) "associative." "not associative."))) )