Toggles the display of the AutoTrack tooltips.
Supported platforms: Windows only
VBA:
object.AutoTrackTooltip
Type: PreferencesDrafting
The object this property applies to.
Read-only: No
Type: Boolean
The initial value for this property is True.
When this property is enabled, the user sees a tooltip whenever the cursor is over an alignment path. When the property is disabled, the tooltip does not show.
VBA:
Sub Example_AutoTrackToolTip() ' This example reads and modifies the preference value that controls ' the display of the AutoTrack tooltips. When finished, this example resets the ' preference value back to its original value. Dim ACADPref As AcadPreferencesDrafting Dim originalValue As Variant, newValue As Variant ' Get the drafting preferences object Set ACADPref = ThisDrawing.Application.preferences.Drafting ' Read and display the original value originalValue = ACADPref.AutoTrackTooltip MsgBox "The AutoTrackToolTip preference is set to: " & originalValue ' Modify the AutoTrackToolTip preference by toggling the value ACADPref.AutoTrackTooltip = Not (originalValue) newValue = ACADPref.AutoTrackTooltip MsgBox "The AutoTrackToolTip preference has been set to: " & newValue ' Reset the preference back to its original value ' ' * Note: Comment out this last section to leave the change to ' this preference in effect ACADPref.AutoTrackTooltip = originalValue MsgBox "The AutoTrackToolTip preference was reset back to: " & originalValue End Sub
Visual LISP:
(vl-load-com) (defun c:Example_AutoTrackToolTip() ;; This example reads and modifies the preference value that controls ;; the display of the AutoTrack tooltips. When finished, this example resets the ;; preference value back to its original value. (setq acadObj (vlax-get-acad-object)) (setq preferences (vla-get-Preferences acadObj)) ;; Get the drafting preferences object (setq ACADPref (vla-get-Drafting preferences)) ;; Read and display the original value (setq originalValue (vla-get-AutoTrackTooltip ACADPref)) (alert (strcat "The AutoTrackToolTip preference is set to: " (if (= originalValue :vlax-true) "True" "False"))) ;; Modify the AutoTrackToolTip preference by toggling the value (vla-put-AutoTrackTooltip ACADPref (if (= originalValue :vlax-true) :vlax-false :vlax-true)) (setq newValue (vla-get-AutoTrackTooltip ACADPref)) (alert (strcat "The AutoTrackToolTip preference has been set to: " (if (= newValue :vlax-true) "True" "False"))) ;; Reset the preference back to its original value ;; ;; * Note: Comment out this last section to leave the change to ;; this preference in effect (vla-put-AutoTrackTooltip ACADPref originalValue) (alert (strcat "The AutoTrackToolTip preference was reset back to: " (if (= originalValue :vlax-true) "True" "False"))) )