PlotHidden Property (ActiveX)

Specifies if objects are to be hidden during a plot.

Supported platforms: Windows only

Signature

VBA:

object.PlotHidden
object

Type: Layout, PlotConfiguration

The objects this property applies to.

Property Value

Read-only: No

Type: Boolean

Remarks

This property specifies if the objects in paper space are processed through the hidden line algorithm. Note that this property does not affect objects inside floating model space viewports.

Examples

VBA:

Sub Example_PlotHidden()
    ' This example will access the Layouts collection for the current drawing
    ' and display whether the objects for each layout are to be hidden during a plot.
    ' It will then toggle the state of PlotHidden for "Layout1" and re-display the
    ' PlotHidden state for each Layout.

    Dim Layouts As AcadLayouts, Layout As ACADLayout
    Dim msg As String
    Dim IsHidden As String
    
    ' Get layouts collection from document object
    Set Layouts = ThisDrawing.Layouts
    
    ' Display current hidden information
    GoSub DISPLAY
    
    ' Toggle object hidden state for Layout1
    Layouts("Layout1").PlotHidden = Not (Layouts("Layout1").PlotHidden)
    
    ' Display new hidden information
    GoSub DISPLAY
    
    Exit Sub
    
DISPLAY:
    msg = ""    ' Clear message
    
    ' Determine whether the objects for each layout are hidden during a plot
    For Each Layout In Layouts
        ' Are these objects hidden?
        IsHidden = IIf(Layout.PlotHidden, " are hidden ", " are not hidden ")
        
        ' Format for display
        msg = msg & "Objects for " & Layout.name & IsHidden & "during a plot." & vbCrLf
    Next
    
    ' Display layout information
    MsgBox msg
    
    Return
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_PlotHidden()
    ;; This example will access the Layouts collection for the current drawing
    ;; and display whether the objects for each layout are to be hidden during a plot.
    ;; It will then toggle the state of PlotHidden for "Layout1" and re-display the
    ;; PlotHidden state for each Layout.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
    
    ;; Get layouts collection from document object
    (setq Layouts (vla-get-Layouts doc))
    
    ;; Display current hidden information
    (setq msg "")
    
    ;; Determine whether the objects for each layout are hidden during a plot
    (vlax-for Layout Layouts
        ;; Are these objects hidden?
        (setq IsHidden (if (= (vla-get-PlotHidden Layout) :vlax-true) " are hidden " " are not hidden "))
        
        ;; Format for display
        (setq msg (strcat msg "Objects for " (vla-get-Name Layout) IsHidden "during a plot.\n"))
    )
    
    ;; Display layout information
    (alert msg)
    
    ;; Toggle object hidden state for Layout1
    (vla-put-PlotHidden (vla-item Layouts "Layout1") (if (= (vla-get-PlotHidden (vla-item Layouts "Layout1")) :vlax-true) :vlax-false :vlax-true))
    
    ;; Display new hidden information
    (setq msg "")
    
    ;; Determine whether the objects for each layout are hidden during a plot
    (vlax-for Layout Layouts
        ;; Are these objects hidden?
        (setq IsHidden (if (= (vla-get-PlotHidden Layout) :vlax-true) " are hidden " " are not hidden "))
        
        ;; Format for display
        (setq msg (strcat msg "Objects for " (vla-get-Name Layout) IsHidden "during a plot.\n"))
    )
    
    ;; Display layout information
    (alert msg)
)