SnapRotationAngle Property (ActiveX)

Specifies the snap rotation angle of the viewport relative to the current UCS.

Supported platforms: Windows only

Signature

VBA:

object.SnapRotationAngle
object

Type: PViewport, Viewport

The objects this property applies to.

Property Value

Read-only: No

Type: Double

The angle in radians. The valid range is 0 to 6.28.

Remarks

You cannot change the snap base point for the active paper space viewport.

Changes to this property are not reflected in the drawing until a call to either the Update or Regen method is performed.

Note: The value of this property is stored in the SNAPANG system variable.

Examples

VBA:

Sub Example_SnapRotationAngle()
    ' This example changes the snap rotation angle for a
    ' model space and paper space viewport.
    
    ' Create a new model space viewport
    Dim viewportObj As AcadViewport
    Set viewportObj = ThisDrawing.Viewports.Add("NewViewport")
    
    ' Find the current snap rotation angle
    Dim currSnapAngle As Double
    currSnapAngle = viewportObj.SnapRotationAngle
    MsgBox "The current model space snap rotation angle is " & viewportObj.SnapRotationAngle, , "SnapRotationAngle Example"
    
    ' Change the snap rotation angle
    viewportObj.SnapRotationAngle = 1.5
    MsgBox "The new model space snap rotation angle is " & viewportObj.SnapRotationAngle, , "SnapRotationAngle Example"
    
    ' Create a new paper space viewport
    Dim pviewportObj As AcadPViewport
    Dim center(0 To 2) As Double
    Dim width As Double
    Dim height As Double
    
    center(0) = 3: center(1) = 3: center(2) = 0
    width = 40
    height = 40
    ThisDrawing.ActiveSpace = acPaperSpace
    Set pviewportObj = ThisDrawing.PaperSpace.AddPViewport(center, width, height)
    
    ' Find the current snap rotation angle
    currSnapAngle = pviewportObj.SnapRotationAngle
    MsgBox "The current paper space snap rotation angle is " & pviewportObj.SnapRotationAngle, , "SnapRotationAngle Example"
    
    ' Change the snap rotation angle
    pviewportObj.SnapRotationAngle = 1.5
    MsgBox "The new paper space snap base point is " & pviewportObj.SnapRotationAngle, , "SnapRotationAngle Example"

End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_SnapRotationAngle()
    ;; This example changes the snap rotation angle for a
    ;; model space and paper space viewport.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))

    ;; Create a new model space viewport
    (setq viewportObj (vla-Add (vla-get-Viewports doc) "NewViewport"))
    
    ;; Find the current snap rotation angle
    (setq currSnapAngle (vla-get-SnapRotationAngle viewportObj))
    (alert (strcat "The current model space snap rotation angle is " (rtos currSnapAngle 2)))
    
    ;; Change the snap rotation angle
    (vla-put-SnapRotationAngle viewportObj 1.5)
    (alert (strcat "The new model space snap rotation angle is " (rtos (vla-get-SnapRotationAngle viewportObj) 2)))
    
    ;; Create a new paper space viewport
    (setq center (vlax-3d-point 3 3 0)
          width 40
	         height 40)
    
    (vla-put-ActiveSpace doc acPaperSpace)
    (setq paperSpace (vla-get-PaperSpace doc))
    (setq pviewportObj (vla-AddPViewport paperSpace center width height))
    
    ;; Find the current snap rotation angle
    (setq currSnapAngle (vla-get-SnapRotationAngle pviewportObj))
    (alert (strcat "The current paper space snap rotation angle is " (rtos currSnapAngle 2)))
    
    ;; Change the snap rotation angle
    (vla-put-SnapRotationAngle pviewportObj 1.5)
    (alert (strcat "The new paper space snap base point is " (rtos (vla-get-SnapRotationAngle pviewportObj) 2)))
)