Display Method (ActiveX)

Toggles the display control of the PViewport object on or off.

Supported platforms: Windows only

Signature

VBA:

object.Display Status
object

Type: PViewport

The object this method applies to.

Status

Access: Input-only

Type: Boolean

  • True: Viewport display is on.
  • False: Viewport display is off.

Return Value (RetVal)

No return value.

Remarks

The display control must be on before the MSpace property can be used to activate the model space editing capabilities.

Use the ViewportOn property to determine if a paper space viewport display has already been turned on with this method.

Examples

VBA:

Sub Example_DisplayMethod()
    ' This example creates a paper space viewport and makes it active.
    
    Dim newPViewport As AcadPViewport
    Dim centerPoint(0 To 2) As Double
    Dim height As Double
    Dim width As Double
    height = 30#
    width = 40#
    centerPoint(0) = 30#: centerPoint(1) = 30#: centerPoint(2) = 0#
    
    ' Create a paper space Viewport object
    ThisDrawing.ActiveSpace = acPaperSpace
    Set newPViewport = ThisDrawing.PaperSpace.AddPViewport(centerPoint, width, height)
    ZoomAll
    newPViewport.Display True
    
    ' Before making a pViewport active,
    ' the mspace property needs to be True
    ThisDrawing.mspace = True
    ThisDrawing.ActivePViewport = newPViewport
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_DisplayMethod()
    ;; This example creates a paper space viewport and makes it active.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
  
    (setq centerPoint (vlax-3d-point 30 30 0)
          height 30
          width 40)
    
    ;; Create a paper space Viewport object
    (vla-put-ActiveSpace doc acPaperSpace)
    (setq newPViewport (vla-AddPViewport (vla-get-PaperSpace doc) centerPoint width height))
    (vla-ZoomAll acadObj)
    (vla-Display newPViewport :vlax-true)
    
    ;; Before making a pViewport active,
    ;; the mspace property needs to be True
    (vla-put-MSpace doc :vlax-true)
    (vla-put-ActivePViewport doc newPViewport)
)