MomentOfInertia Property (ActiveX)

Gets the moment of inertia for the solid.

Supported platforms: Windows only

Signature

VBA:

object.MomentOfInertia
object

Type: 3DSolid, Region

The objects this property applies to.

Property Value

Read-only: Yes

Type: Variant (three-element array of doubles)

A 3D coordinate based on the current coordinate system.

Remarks

The moment of inertia is returned as X, Y, and Z coordinates defined as a variant.

Examples

VBA:

Sub Example_MomentOfInertia()
    ' This example creates a box in model space.
    ' It then returns the MomentOfInertia for that box.
        
    Dim boxObj As Acad3DSolid
    Dim length As Double, width As Double, height As Double
    Dim center(0 To 2) As Double
    
    ' Define the box
    center(0) = 5#: center(1) = 5#: center(2) = 0
    length = 5#: width = 7: height = 10#
    
    ' Create the box (3DSolid) object in model space
    Set boxObj = ThisDrawing.ModelSpace.AddBox(center, length, width, height)
    
    ' Change the viewing direction of the viewport to better see the box
    Dim NewDirection(0 To 2) As Double
    NewDirection(0) = -1: NewDirection(1) = -1: NewDirection(2) = 1
    ThisDrawing.ActiveViewport.direction = NewDirection
    ThisDrawing.ActiveViewport = ThisDrawing.ActiveViewport
    ZoomAll
    
    ' Return the MomentOfInertia for the box
    Dim momentOfInertia As Variant
    momentOfInertia = boxObj.momentOfInertia
    MsgBox "The MomentOfInertia for the box is " & momentOfInertia(0) & ", " & momentOfInertia(1) & ", " & momentOfInertia(2), , "MomentOfInertia Example"
        
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_MomentOfInertia()
    ;; This example creates a box in model space.
    ;; It then returns the MomentOfInertia for that box.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
    
    ;; Define the box
    (setq center (vlax-3d-point 5 5 0)
          boxLength 5
	  boxWidth 7
	  boxHeight 10)
    
    ;; Create the box (3DSolid) object in model space
    (setq modelSpace (vla-get-ModelSpace doc))
    (setq boxObj (vla-AddBox modelSpace center boxLength boxWidth boxHeight))
    
    ;; Change the viewing direction of the viewport to better see the box
    (setq NewDirection (vlax-3d-point -1 -1 1))
    (setq activeViewport (vla-get-ActiveViewport doc))
    (vla-put-Direction activeViewport NewDirection)
    (vla-put-ActiveViewport doc activeViewport)
    (vla-ZoomAll acadObj)
    
    ;; Return the MomentOfInertia for the box
    (setq momentOfInertia (vlax-variant-value (vla-get-MomentOfInertia boxObj)))
    (alert (strcat "The MomentOfInertia for the box is " (rtos (vlax-safearray-get-element momentOfInertia 0) 2) ", "
                                                         (rtos (vlax-safearray-get-element momentOfInertia 1) 2) ", "
                                                         (rtos (vlax-safearray-get-element momentOfInertia 2) 2)))
)