ExtLine1StartPoint Property (ActiveX)

Specifies the start point of the first extension line.

Supported platforms: Windows only

Signature

VBA:

object.ExtLine1StartPoint
object

Type: DimAngular

The object this property applies to.

Property Value

Read-only: No

Type: Variant (three-element array of doubles)

A 3D coordinate representing the start point of the first extension line.

Remarks

The ExtLine1StartPoint and ExtLine2StartPoint properties are equal to the FirstEndPoint and SecondEndPoint parameters from the AddDimAngular method. The extension lines are originally drawn from the FirstEndPoint and SecondEndPoint locations to the intersection of the dimension line. AutoCAD draws the dimension line as an arc between the extension lines.



Examples

VBA:

Sub Example_ExtLine1StartPoint()
    ' This example creates an angular dimension. It then changes
    ' the location of the ExtLine1StartPoint.
    
    Dim dimObj As AcadDimAngular
    Dim angVert(0 To 2) As Double
    Dim FirstPoint(0 To 2) As Double
    Dim SecondPoint(0 To 2) As Double
    Dim TextPoint(0 To 2) As Double
    
    ' Define the dimension
    angVert(0) = 0#: angVert(1) = 5#: angVert(2) = 0#
    FirstPoint(0) = 1#: FirstPoint(1) = 7#: FirstPoint(2) = 0#
    SecondPoint(0) = 1#: SecondPoint(1) = 3#: SecondPoint(2) = 0#
    TextPoint(0) = 3#: TextPoint(1) = 5#: TextPoint(2) = 0#
    
    ' Create the angular dimension in model space
    Set dimObj = ThisDrawing.ModelSpace.AddDimAngular(angVert, FirstPoint, SecondPoint, TextPoint)
    ZoomAll
    MsgBox "The current value of ExtLine1StartPoint is " & dimObj.ExtLine1StartPoint(0) & ", " & dimObj.ExtLine1StartPoint(1) & ", " & dimObj.ExtLine1StartPoint(2), vbInformation, "ExtLine1StartPoint Example"
    
    ' Change the start point of the first extension line
    FirstPoint(0) = 0: FirstPoint(1) = 3: FirstPoint(2) = 0
    dimObj.ExtLine1StartPoint = FirstPoint
    dimObj.Update
    
    ' Return the start point of the first extension line
    ' Note that the return value is a Variant
    Dim retPnt As Variant
    retPnt = dimObj.ExtLine1StartPoint
    MsgBox "The new value of ExtLine1StartPoint is " & dimObj.ExtLine1StartPoint(0) & ", " & dimObj.ExtLine1StartPoint(1) & ", " & dimObj.ExtLine1StartPoint(2), vbInformation, "ExtLine1StartPoint Example"
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_ExtLine1StartPoint()
    ;; This example creates an angular dimension. It then changes
    ;; the location of the ExtLine1StartPoint.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
    
    ;; Define the dimension
    (setq AngleVertex (vlax-3d-point 0 5 0)
          FirstPoint (vlax-3d-point 1 7 0)
          SecondPoint (vlax-3d-point 1 3 0)
          TextPoint (vlax-3d-point 3 5 0))

    ;; Create the angular dimension in model space
    (setq modelSpace (vla-get-ModelSpace doc))  
    (setq dimObj (vla-AddDimAngular modelSpace AngleVertex FirstPoint SecondPoint TextPoint))
    (vla-ZoomAll acadObj)

    (setq extLineStartPoint (vlax-safearray->list (vlax-variant-value (vla-get-ExtLine1StartPoint dimObj))))
    (alert (strcat "The current value of ExtLine1StartPoint is " (rtos (nth 0 extLineStartPoint) 2) ", "
		                                                 (rtos (nth 1 extLineStartPoint) 2) ", "
		                                                 (rtos (nth 2 extLineStartPoint) 2)))
    
    ;; Change the start point of the first extension line
    (setq FirstPoint (vlax-3d-point 0 3 0))
    (vla-put-ExtLine1StartPoint dimObj FirstPoint)
    (vla-Update dimObj)
    
    ;; Return the start point of the first extension line
    ;; Note that the return value is a Variant
    (setq retPnt (vlax-safearray->list (vlax-variant-value (vla-get-ExtLine1StartPoint dimObj))))
    (alert (strcat "The new value of ExtLine1StartPoint is " (rtos (nth 0 retPnt) 2) ", "
		                                             (rtos (nth 1 retPnt) 2) ", "
		                                             (rtos (nth 2 retPnt) 2)))
)