Toolbars Property (ActiveX)

Gets the Toolbars collection.

Supported platforms: Windows only

Signature

VBA:

object.Toolbars
object

Type: MenuGroup

The object this property applies to.

Property Value

Read-only: Yes

Type: Toolbars

A user-specified variable declared as a Toolbars collection.

Remarks

No additional remarks.

Examples

VBA:

Sub Example_Toolbars()
    ' This example finds the names of the all toolbars in the first menu group.
    
    Dim toolbarNames As String
    Dim toolbarCollection As AcadToolbars
    Dim toolbar As AcadToolbar
    
    Set toolbarCollection = ThisDrawing.Application.MenuGroups.Item(0).Toolbars
    toolbarNames = ""
    For Each toolbar In toolbarCollection
        toolbarNames = toolbarNames & toolbar.name & vbCrLf
    Next toolbar
    MsgBox toolbarNames
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_Toolbars()
    ;; This example finds the names of the all toolbars in the first menu group.
    (setq acadObj (vlax-get-acad-object))    
    
    (setq toolbarCollection (vla-get-Toolbars (vla-Item (vla-get-MenuGroups acadObj) 0))
          toolbarNames "")
    
    (vlax-for toolbar toolbarCollection
        (setq toolbarNames (strcat toolbarNames (vla-get-Name toolbar) "\n"))
    )
  
    (alert toolbarNames)
)