UnloadARX Method (ActiveX)

Unloads the specified AutoCAD ARX application.

Supported platforms: Windows only

Signature

VBA:

object.UnloadARX Name
object

Type: Application

The object this method applies to.

Name

Access: Input-only

Type: String

The name of the application to unload.

Return Value (RetVal)

No return value.

Remarks

If the specified application is locked when this method is called, the method will fail.

Note: Do not attempt to unload the file acvba.arx.

Examples

VBA:

Sub Example_UnLoadARX()
    ' This example unloads an ObjectARX application from the AutoCAD session.
    
    ' Note: The application listed here does not exist and
    ' will cause an error when run. Change the application name
    ' to the name of your ObjectARX application.
    On Error GoTo ERRORHANDLER
    ThisDrawing.Application.UnloadArx "MyARXApp.arx"
        
ERRORHANDLER:
    MsgBox Err.Description, , "UnloadARX"
    
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_UnloadARX()
    ;; This example unloads an ObjectARX application from the AutoCAD session.
    (setq acadObj (vlax-get-acad-object))

    ;; Note: The application listed here does not exist and
    ;; will cause an error when run. Change the application name
    ;; to the name of your ObjectARX application.
    (vla-UnloadArx acadObj "MyARXApp.arx")
)