Specifies the default plot style table to attach to new drawings.
Supported platforms: Windows only
VBA:
object.DefaultPlotStyleTable
Type: PreferencesOutput
The object this property applies to.
Read-only: No
Type: String
A plot style table has a .ctb or .stb extension and includes and defines plot styles.
If you are using color-dependent plot styles, this option can be set to any color dependent plot style tables found in the search path as well as the value "None". If you are using named plot styles, this option can be set to any named plot style tables.
To set color-dependent plot styles, use the PlotPolicy property.
VBA:
Sub Example_DefaultPlotStyleTable() ' This example reads and modifies the preference value that ' specifies the default plot style table to attach to new drawings. ' ' Note: You may want to change the path of the new plot style table below. Dim ACADPref As AcadPreferencesOutput Dim CurrentFile As String Const NewFile = "c:\monochrome.ctb" ' Get the drafting preferences object Set ACADPref = ThisDrawing.Application.preferences.Output ' Read and display the current plot style table path CurrentFile = ACADPref.DefaultPlotStyleTable If CurrentFile = "" Then MsgBox "There is no current plot style table being used", vbInformation Else MsgBox "The current plot style table is: " & CurrentFile End If ' Use a new plot style table ACADPref.DefaultPlotStyleTable = NewFile ' Read and display the new plot style table path CurrentFile = ACADPref.DefaultPlotStyleTable MsgBox "The new plot style table is: " & CurrentFile, vbInformation End Sub
Visual LISP:
(vl-load-com) (defun c:Example_DefaultPlotStyleTable() ;; This example reads and modifies the preference value that ;; specifies the default plot style table to attach to new drawings. ;; ;; Note: You may want to change the path of the new plot style table below. (setq acadObj (vlax-get-acad-object)) (setq preferences (vla-get-Preferences acadObj)) (setq NewFile (strcat (vla-get-PrinterStyleSheetPath (vla-get-Files preferences)) "\\monochrome.ctb")) ;; Get the drafting preferences object (setq ACADPref (vla-get-Output preferences)) ;; Read and display the current plot style table path (setq CurrentFile (vla-get-DefaultPlotStyleTable ACADPref)) (if (= CurrentFile "") (alert "There is no current plot style table being used.") (alert (strcat "The current plot style table is: " CurrentFile)) ) ;; Use a new plot style table (vla-put-DefaultPlotStyleTable ACADPref NewFile) ;; Read and display the new plot style table path (alert (strcat "The new plot style table is: " (vla-get-DefaultPlotStyleTable ACADPref))) (vla-put-DefaultPlotStyleTable ACADPref CurrentFile) )