Display Property (ActiveX)

Gets the PreferencesDisplay object.

Supported platforms: Windows only

Signature

VBA:

object.Display
object

Type: Preferences

The object this property applies to.

Property Value

Read-only: Yes

Type: PreferencesDisplay

Gets the PreferencesDisplay object.

Remarks

The PreferencesDisplay object holds all the options from the Display tab on the Options dialog stored in the registry. All options that are stored with the drawing can be found on the DatabasePreferences object.

Examples

VBA:

Sub Example_Display()
    ' This example obtains a reference to the Display Preferences object
    ' from the Application Preferences object, and reads one of the Display
    ' preferences
    
    Dim ACADPref As AcadPreferencesDisplay
    
    ' Obtain a reference to the Display Preferences object
    Set ACADPref = ThisDrawing.Application.Preferences.Display
    
    MsgBox "We now have access to the properties and methods of the Display Preferences object!"
    MsgBox "The Display preference CursorSize is set to: " & ACADPref.CursorSize

End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_Display()
    ;; This example obtains a reference to the Display Preferences object
    ;; from the Application Preferences object, and reads one of the Display
    ;; preferences
    (setq acadObj (vlax-get-acad-object))
    (setq preferences (vla-get-Preferences acadObj))
  
    ;; Obtain a reference to the Display Preferences object
    (setq ACADPref (vla-get-Display preferences))
    
    (alert "We now have access to the properties and methods of the Display Preferences object!")
    (alert (strcat "The Display preference CursorSize is set to: " (itoa (vla-get-CursorSize ACADPref))))
)