DoglegLength Property (ActiveX)

The length of the dog-leg.

Supported platforms: Windows only

Signature

VBA:

object.DoglegLength
object

Type: MLeader, MLeaderStyle

The object this property applies to.

Property Value

Read-only: No

Type: Double

Specifies the landing distance.

Remarks

No additional remarks.

Examples

VBA:

Sub Example_DogLeg()
    Dim oML As AcadMLeader
    Dim points(0 To 14) As Double
    
    ' Define the leader points
    points(0) = 1: points(1) = 1: points(2) = 0
    points(3) = 1: points(4) = 2: points(5) = 0
    points(6) = 2: points(7) = 2: points(8) = 0
    points(9) = 3: points(10) = 2: points(11) = 0
    points(12) = 4: points(13) = 4: points(14) = 0
    Dim i As Long
    Set oML = ThisDrawing.ModelSpace.AddMLeader(points, i)
    
    oML.DogLegged = True
    oML.DoglegLength = 1.3

    MsgBox "The dog-leg length is  " & oML.DoglegLength

    ZoomAll

End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_DogLeg()
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))

    ;; Define the leader points
    (setq points (vlax-make-safearray vlax-vbDouble '(0 . 14)))
    (vlax-safearray-fill points '(1 1 0
				                              1 2 0
				                              2 2 0
				                              3 2 0
				                              4 4 0
				                             )
    )
    (setq i 0)
    (setq modelSpace (vla-get-ModelSpace doc))
    (setq oML (vla-AddMLeader modelSpace points i))
    
    (vla-put-DogLegged oML :vlax-true)
    (vla-put-DoglegLength oML 1.3)

    (alert (strcat "The dog-leg length is " (rtos (vla-get-DoglegLength oML) 2)))

    (vla-ZoomAll acadObj)
)