AddLine Method (ActiveX)

Creates a line passing through two points.

Supported platforms: Windows only

Signature

VBA:

RetVal = object.AddLine(StartPoint, EndPoint)
object

Type: Block, ModelSpace, PaperSpace

The objects this method applies to.

StartPoint

Access: Input-only

Type: Variant (three-element array of doubles)

The 3D WCS coordinates specifying the line start point.

EndPoint

Access: Input-only

Type: Variant (three-element array of doubles)

The 3D WCS coordinates specifying the line endpoint.

Return Value (RetVal)

Type: Line

The newly created Line object.

Remarks

No additional remarks.

Examples

VBA:

Sub Example_AddLine()
    ' This example adds a line in model space
    
    Dim lineObj As AcadLine
    Dim startPoint(0 To 2) As Double
    Dim endPoint(0 To 2) As Double
    
    ' Define the start and end points for the line
    startPoint(0) = 1#: startPoint(1) = 1#: startPoint(2) = 0#
    endPoint(0) = 5#: endPoint(1) = 5#: endPoint(2) = 0#
    
    ' Create the line in model space
    Set lineObj = ThisDrawing.ModelSpace.AddLine(startPoint, endPoint)
    ZoomAll
    
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_AddLine()
    ;; This example adds a line in model space
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
    
    ;; Define the start and end points for the line
    (setq startPoint (vlax-3d-point 1 1 0)
          endPoint (vlax-3d-point 5 5 0))
    
    ;; Create the line in model space
    (setq modelSpace (vla-get-ModelSpace doc))
    (setq lineObj (vla-AddLine modelSpace startPoint endPoint))
    (vla-ZoomAll acadObj)
)