ListARX Method (ActiveX)

Gets the currently loaded ObjectARX applications.

Supported platforms: Windows only

Signature

VBA:

RetVal = object.ListArx
object

Type: Application

The object this method applies to.

Return Value (RetVal)

Type: Variant

An array of ObjectARX applications currently loaded. Returns empty if no applications are currently loaded.

Remarks

No additional remarks.

Examples

VBA:

Sub Example_ListARX()
    ' This example gets all the loaded ObjectARX applications
    
    ' Get the list of applications
    Dim appList As Variant
    appList = ThisDrawing.Application.ListArx
    
    ' Iterate through the list, and display the names, if any.
    If VarType(appList) <> vbEmpty Then
        Dim I As Integer
        For I = LBound(appList) To UBound(appList)
            MsgBox "ObjectARX application name: " & appList(I)
        Next
    Else
        MsgBox "No ObjectARX applications present."
    End If
    
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_ListARX()
    ;; This example gets all the loaded ObjectARX applications
    (setq acadObj (vlax-get-acad-object))
  
    ;; Get the list of applications
    (setq appList (vla-ListArx acadObj))
    
    ;; Iterate through the list, and display the names, if any.
    (if (/= (vlax-variant-value appList) vlax-vbEmpty)
        (progn
            (setq I 0
                  appList (vlax-variant-value appList))
            (while (>= (vlax-safearray-get-u-bound appList 1) I)
                (alert (strcat "ObjectARX application name: " (vlax-safearray-get-element appList I)))
                (setq I (1+ I))
            )
        )
        (alert "No ObjectARX applications present.")
    )
)