HistoryLines Property (ActiveX)

Specifies the number of lines of text in the text window to keep in memory.

Supported platforms: Windows only

Signature

VBA:

object.HistoryLines
object

Type: PreferencesDisplay

The object this property applies to.

Property Value

Read-only: No

Type: Integer

The initial value is 400.

Remarks

No additional remarks.

Examples

VBA:

Sub Example_HistoryLines()
    ' This example returns the current setting of
    ' HistoryLines. It then changes the value, and finally
    ' it resets the value back to the original setting.
    
    Dim preferences As AcadPreferences
    Dim currHistoryLines As Integer
    
    Set preferences = ThisDrawing.Application.preferences
    
    ' Retrieve the current HistoryLines value
    currHistoryLines = preferences.DISPLAY.HistoryLines
    MsgBox "The current value for HistoryLines is " & preferences.DISPLAY.HistoryLines, vbInformation, "HistoryLines Example"
    
    ' Change the value for HistoryLines
    preferences.DISPLAY.HistoryLines = 42
    MsgBox "The new value for HistoryLines is " & preferences.DISPLAY.HistoryLines, vbInformation, "HistoryLines Example"
    
    ' Reset HistoryLines to its original value
    preferences.DISPLAY.HistoryLines = currHistoryLines
    MsgBox "The HistoryLines value is reset to " & preferences.DISPLAY.HistoryLines, vbInformation, "HistoryLines Example"
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_HistoryLines()
    ;; This example returns the current setting of
    ;; HistoryLines. It then changes the value, and finally
    ;; it resets the value back to the original setting.
    (setq acadObj (vlax-get-acad-object))
    (setq preferences (vla-get-Preferences acadObj))
    
    ;; Retrieve the current HistoryLines value
    (setq currHistoryLines (vla-get-HistoryLines (vla-get-Display preferences)))
    (alert (strcat "The current value for HistoryLines is " (itoa currHistoryLines)))
    
    ;; Change the value for HistoryLines
    (vla-put-HistoryLines (vla-get-Display preferences) 42)
    (alert (strcat "The new value for HistoryLines is " (itoa (vla-get-HistoryLines (vla-get-Display preferences)))))
    
    ;; Reset HistoryLines to its original value
    (vla-put-HistoryLines (vla-get-Display preferences) currHistoryLines)
    (alert (strcat "The HistoryLines value is reset to " (itoa (vla-get-HistoryLines (vla-get-Display preferences)))))
)