Profiles Property (ActiveX)

Gets the PreferencesProfiles object.

Supported platforms: Windows only

Signature

VBA:

object.Profiles
object

Type: Preferences

The object this property applies to.

Property Value

Read-only: Yes

Type: PreferencesProfiles

Gets the PreferencesProfiles object.

Remarks

The PreferencesProfiles object holds all the options from the Profiles tab on the Options dialog stored in the registry. All options that are stored with the drawing can be found on the DatabasePreferences object.

Examples

VBA:

Sub Example_Profiles()
    ' This example obtains a reference to the Profiles Preferences object
    ' from the Application Preferences object, and reads one of the Profiles
    ' preferences
    
    Dim ACADPref As AcadPreferencesProfiles
    
    ' Obtain a reference to the Profiles Preferences object
    Set ACADPref = ThisDrawing.Application.Preferences.Profiles
    
    MsgBox "You now have access to the properties and methods of the Profiles Preferences object!"
    MsgBox "The Profiles preference ActiveProfile is set to: " & ACADPref.ActiveProfile

End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_Profiles()
    ;; This example obtains a reference to the Profiles Preferences object
    ;; from the Application Preferences object, and reads one of the Profiles
    ;; preferences
    (setq acadObj (vlax-get-acad-object))
    (setq preferences (vla-get-Preferences acadObj))
    
    ;; Obtain a reference to the Profiles Preferences object
    (alert "You now have access to the properties and methods of the Profiles Preferences object!")
    (alert (strcat "The Profiles preference ActiveProfile is set to: " (vla-get-ActiveProfile (vla-get-Profiles preferences))))
)