EnableStartupDialog Property (ActiveX)

Specifies whether a startup dialog box is displayed when AutoCAD is launched or a new drawing is created.

Supported platforms: Windows only

Signature

VBA:

object.EnableStartupDialog
object

Type: PreferencesSystem

The object this property applies to.

Property Value

Read-only: No

Type: Boolean

Remarks

The initial value for this property is False.

The traditional startup dialog box can be displayed when EnableStartupDialog is True.

Examples

VBA:

Sub Example_EnableStartupDialog()
    ' This example returns the current setting of
    ' EnableStartupDialog. It then changes the value, and finally
    ' it resets the value back to the original setting.
    
    Dim preferences As AcadPreferences
    Dim currEnableStartupDialog As Boolean
    
    Set preferences = ThisDrawing.Application.preferences
    
    ' Retrieve the current EnableStartupDialog value
    currEnableStartupDialog = preferences.System.EnableStartupDialog
    MsgBox "The current value for EnableStartupDialog is " & preferences.System.EnableStartupDialog, vbInformation, "EnableStartupDialog Example"
    
    ' Change the value for EnableStartupDialog
    preferences.System.EnableStartupDialog = Not (currEnableStartupDialog)
    MsgBox "The new value for EnableStartupDialog is " & preferences.System.EnableStartupDialog, vbInformation, "EnableStartupDialog Example"
    
    ' Reset EnableStartupDialog to its original value
    preferences.System.EnableStartupDialog = currEnableStartupDialog
    MsgBox "The EnableStartupDialog value is reset to " & preferences.System.EnableStartupDialog, vbInformation, "EnableStartupDialog Example"
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_EnableStartupDialog()
    ;; This example returns the current setting of
    ;; EnableStartupDialog. It then changes the value, and finally
    ;; it resets the value back to the original setting.
    (setq acadObj (vlax-get-acad-object))
    (setq preferences (vla-get-Preferences acadObj))
    
    ;; Get the system preferences object
    (setq ACADPref (vla-get-System preferences))
    
    ;; Retrieve the current EnableStartupDialog value
    (setq currEnableStartupDialog (vla-get-EnableStartupDialog ACADPref))
    (alert (strcat "The current value for EnableStartupDialog is " (if (= currEnableStartupDialog :vlax-true) "True" "False")))
  
    ;; Change the value for EnableStartupDialog
    (vla-put-EnableStartupDialog ACADPref (if (= currEnableStartupDialog :vlax-true) :vlax-false :vlax-true))
    (setq newValue (vla-get-EnableStartupDialog ACADPref))
    (alert (strcat "The new value for EnableStartupDialog is " (if (= newValue :vlax-true) "True" "False")))
    
    ;; Reset EnableStartupDialog to its original value
    (vla-put-EnableStartupDialog ACADPref currEnableStartupDialog)
    (alert (strcat "The EnableStartupDialog value is reset to " (if (= currEnableStartupDialog :vlax-true) "True" "False")))
)