LayoutDisplayPaper Property (ActiveX)

Toggles the display of the paper background in layouts.

Supported platforms: Windows only

Signature

VBA:

object.LayoutDisplayPaper
object

Type: PreferencesDisplay

The object this property applies to.

Property Value

Read-only: No

Type: Boolean

Remarks

The initial value for this property is True.

Examples

VBA:

Sub Example_LayoutDisplayPaper()
    ' This example reads and modifies the preference value that controls
    ' the display of the paper background in layouts. When finished, this example
    ' resets the preference value back to its original value.
    
    Dim ACADPref As AcadPreferencesDisplay
    Dim originalValue As Variant, newValue As Variant
    
    ' Get the display preferences object
    Set ACADPref = ThisDrawing.Application.preferences.DISPLAY
    
    ' Switch to paper space to view this change
    ThisDrawing.ActiveSpace = acPaperSpace
    
    ' Read and display the original value
    originalValue = ACADPref.LayoutDisplayPaper
    MsgBox "The LayoutDisplayPaper preference is set to: " & originalValue

    ' Modify the LayoutDisplayPaper preference by toggling the value
    ACADPref.LayoutDisplayPaper = Not (originalValue)
    newValue = ACADPref.LayoutDisplayPaper
    ThisDrawing.Regen acAllViewports

    MsgBox "The LayoutDisplayPaper preference has been set to: " & newValue

    ' Reset the preference back to its original value
    '
    ' * Note: Comment out this last section to leave the change to
    '         this preference in effect
    ACADPref.LayoutDisplayPaper = originalValue
    ThisDrawing.Regen acAllViewports
    
    MsgBox "The LayoutDisplayPaper preference was reset back to: " & originalValue
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_LayoutDisplayPaper()
    ;; This example reads and modifies the preference value that controls
    ;; the display of the paper background in layouts. When finished, this example
    ;; resets the preference value back to its original value.
    (setq acadObj (vlax-get-acad-object))
    (setq preferences (vla-get-Preferences acadObj))
    
    ;; Switch to paper space to view this change
    (vla-put-ActiveSpace doc acPaperSpace)
    
    ;; Read and display the original value
    (setq originalValue (vla-get-LayoutDisplayPaper (vla-get-Display preferences)))
    (alert (strcat "The LayoutDisplayPaper preference is set to: " (if (= originalValue :vlax-true) "True"  "False")))

    ;; Modify the LayoutDisplayPaper preference by toggling the value
    (vla-put-LayoutDisplayPaper (vla-get-Display preferences) (if (= originalValue :vlax-true) :vlax-false :vlax-true))
    (setq newValue (vla-get-LayoutDisplayPaper (vla-get-Display preferences)))
    (vla-Regen doc acAllViewports)

    (alert (strcat "The LayoutDisplayPaper preference has been set to: " (if (= newValue :vlax-true) "True"  "False")))

    ;; Reset the preference back to its original value
    ;;
    ;; * Note: Comment out this last section to leave the change to
    ;;         this preference in effect
    (vla-put-LayoutDisplayPaper (vla-get-Display preferences) originalValue)
    (vla-Regen doc acAllViewports)
    
    (alert (strcat "The LayoutDisplayPaper preference was reset back to: " (if (= originalValue :vlax-true) "True"  "False")))
)