DisplayGrips Property (ActiveX)

Controls the display of selection set grips for the Stretch, Move, Rotate, Scale, and Mirror grip modes.

Supported platforms: Windows only

Signature

VBA:

object.DisplayGrips
object

Type: PreferencesSelection

The object this property applies to.

Property Value

Read-only: No

Type: Boolean

Remarks

The initial value of this property is True.

To adjust the size of the grips and the effective selection area used by the cursor when you snap to a grip, use the GripSize property.

To adjust the color of selected or unselected grips, use the GripColorSelected or GripColorUnselected properties.

Note: The value for this property is stored in the GRIPS system variable.

Examples

VBA:

Sub Example_DisplayGrips()
    ' This example reads and modifies the preference value that controls
    ' the display of selection set grips for the Stretch, Move, Rotate,
    ' Scale, and Mirror grip modes.
    ' When finished, this example resets the preference value back to
    ' its original value.
    
    Dim ACADPref As AcadPreferencesSelection
    Dim originalValue As Variant, newValue As Variant
    
    ' Get the selection preferences object
    Set ACADPref = ThisDrawing.Application.Preferences.Selection
    
    ' Read and display the original value
    originalValue = ACADPref.DisplayGrips
    MsgBox "The DisplayGrips preference is set to: " & originalValue

    ' Modify the DisplayGrips preference by toggling the value
    ACADPref.DisplayGrips = Not (originalValue)
    newValue = ACADPref.DisplayGrips
    MsgBox "The DisplayGrips preference has been set to: " & newValue

    ' Reset the preference back to its original value
    '
    ' * Note: Comment out this last section to leave the change to
    '         this preference in effect
    ACADPref.DisplayGrips = originalValue
    MsgBox "The DisplayGrips preference was reset back to: " & originalValue
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_DisplayGrips()
    ;; This example reads and modifies the preference value that controls
    ;; the display of selection set grips for the Stretch, Move, Rotate,
    ;; Scale, and Mirror grip modes.
    ;; When finished, this example resets the preference value back to
    ;; its original value.
    (setq acadObj (vlax-get-acad-object))
    (setq preferences (vla-get-Preferences acadObj))
    
    ;; Get the selection preferences object
    (setq ACADPref (vla-get-Selection preferences))
    
    ;; Read and display the original value
    (setq originalValue (vla-get-DisplayGrips ACADPref))
    (alert (strcat "The DisplayGrips preference is set to: " (if (= originalValue :vlax-true) "True" "False")))

    ;; Modify the DisplayGrips preference by toggling the value
    (vla-put-DisplayGrips ACADPref (if (= originalValue :vlax-true) :vlax-false :vlax-true))
    (setq newValue (vla-get-DisplayGrips ACADPref))
    (alert (strcat "The DisplayGrips preference has been set to: " (if (= newValue :vlax-true) "True" "False")))

    ;; Reset the preference back to its original value
    ;;
    ;; * Note: Comment out this last section to leave the change to
    ;;         this preference in effect
    (vla-put-DisplayGrips ACADPref originalValue)
    (alert (strcat "The DisplayGrips preference was reset back to: " (if (= originalValue :vlax-true) "True" "False")))
)