Specifies the serial number of the digital certificate.
Supported platforms: Windows only
Read-only: No
Type: String
The serial number of the digital certificate.
No additional remarks.
VBA:
Sub Example_SerialNumber() ' This example attaches a digital signature and accompanying data to a file, ' and saves the file. Dim sp As AcadSecurityParams Set sp = GetInterfaceObject("AutoCAD.SecurityParams." + Left(AcadApplication.Version, 2)) ' Attach a digital signature and timestamp it sp.Action = AcadSecurityParamsType.ACADSECURITYPARAMS_SIGN_DATA _ + AcadSecurityParamsType.ACADSECURITYPARAMS_ADD_TIMESTAMP ' Certificate details follow sp.Subject = "Thawte Freemail Member" sp.Issuer = "Personal Freemail RSA 2000.8.30" sp.SerialNumber = "073848" sp.Comment = "This is now signed" sp.TimeServer = "NIST(time.nist.gov)" ThisDrawing.SaveAs "C:\MyDrawing.dwg", , sp End Sub
Visual LISP:
(vl-load-com) (defun c:Example_SerialNumber() ;; This example attaches a digital signature and accompanying data to a file, ;; and saves the file. (setq acadObj (vlax-get-acad-object)) (setq sp (vlax-create-object (strcat "AutoCAD.SecurityParams." (substr (getvar "ACADVER") 1 2)))) (vla-put-Visible acadObj :vlax-true) ;; Attach a digital signature and timestamp it (vla-put-Action sp (+ ACADSECURITYPARAMS_SIGN_DATA ACADSECURITYPARAMS_ADD_TIMESTAMP)) ;; Certificate details follow (vla-put-Subject sp "Thawte Freemail Member") (vla-put-Issuer sp "Personal Freemail RSA 2000.8.30") (vla-put-SerialNumber sp "073848") (vla-put-Comment sp "This is now signed") (vla-put-TimeServer sp "NIST(time.nist.gov)") (setq doc (vla-get-ActiveDocument acadObj)) (vla-SaveAs doc "C:\\MyDrawing.dwg" acNative sp) (vlax-release-object sp) )