GetName Method (ActiveX)

Gets the name (keyword) of an object in a dictionary.

Supported platforms: Windows only

Signature

VBA:

RetVal = object.GetName(Object)
object

Type: Dictionary

The object this method applies to.

Object

Access: Input-only

Type: Object

The object to query.

Return Value (RetVal)

Type: String

The name (keyword) of the object.

Remarks

For example, querying the object "Object2" in the following dictionary would return the name "SecondKeyword":

MyDictionary

Keyword - Object

FirstKeyword - Object1

SecondKeyword - Object2

Examples

VBA:

Sub Example_GetName()
    ' This example creates a dictionary and adds
    ' a custom object to that dictionary. It then
    ' finds the name of the object in the dictionary.
    
    Dim dictObj As AcadDictionary
    Set dictObj = ThisDrawing.Dictionaries.Add("TEST_DICTIONARY")
    
    ' Load the ObjectARX application that defines the custom object.
    ' Note: The application listed here does not exist and
    ' will cause an error when run. Change the application name
    ' to the path and name of your ObjectARX application.
    ThisDrawing.Application.LoadArx "MyARXApp.dll"
    
    ' Create the custom object in the dictionary
    Dim keyName As String
    Dim className As String
    Dim customObj As AcadObject
    
    keyName = "OBJ1"
    className = "CAsdkDictObject"
    
    Set customObj = dictObj.AddObject(keyName, className)
    
    ' Find the keyword name of an object in the dictionary
    keyName = dictObj.GetName(customObj)
    
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_GetName()
    ;; This example creates a dictionary and adds
    ;; a custom object to that dictionary.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
    (setq dictionaries (vla-get-Dictionaries doc))
  
    (setq dictObj (vla-Add dictionaries "TEST_DICTIONARY"))
    
    ;; Load the ObjectARX application that defines the custom object.
    ;; Note: The application listed here does not exist and
    ;; will cause an error when run. Change the application name
    ;; to the path and name of your ObjectARX application.
    (vla-LoadArx acadObj "MyARXApp.dll")
    
    ;; Create the custom object in the dictionary
    (setq keyName "OBJ1")
    (setq className "CAsdkDictObject")

    (setq customObj (vla-AddObject dictObj keyName className))

    ;; Find the keyword name of an object in the dictionary
    (setq keyName (vla-GetName dictObj customObj))
)