AddDimRadialLarge Method (ActiveX)

Creates a jogged radial dimension for an arc, circle, or polyline arc segment.

Supported platforms: Windows only

Signature

VBA:

RetVal = object.AddDimRadialLarge(Center, ChordPoint, OverrideCenter, JogPoint, JogAngle)
object

Type: Block, ModelSpace, PaperSpace

The object this method applies to.

Center

Access: Input-only

Type: Variant (three-element array of doubles)

The 3D WCS coordinates specifying the center of the arc, circle, or polyline arc segment.

ChordPoint

Access: Input-only

Type: Variant (three-element array of doubles)

The 3D WCS coordinates specifying the chord point for the arc.

OverrideCenter

Access: Input-only

Type: Variant (three-element array of doubles)

The 3D WCS coordinates specifying the override center location or pick point.

JogPoint

Access: Input-only

Type: Variant (three-element array of doubles)

The 3D WCS coordinates specifying the jog location or pick point.

JogAngle

Access: Input-only

Type: Double

The value for the jog angle.

Return Value (RetVal)

Type: DimRadialLarge

The newly created jogged radius dimension.

Remarks



The Center is the center of the arc, circle, or polyline arc segment being dimensioned. The OverrideCenter is the origin point of the dimension.

Examples

VBA:

Sub Example_AddDimRadialLarge()
    Dim PI As Double: PI = 3.141592
    Dim oMS As AcadModelSpace
    Set oMS = ThisDrawing.ModelSpace
    
    Dim ptCenter(2) As Double
    Dim oA As AcadArc
    Set oA = oMS.AddArc(ptCenter, 10, PI / 3, PI * 3 / 4)

    Dim ptChordPoint(2) As Double
    ptChordPoint(0) = 0: ptChordPoint(1) = 10: ptChordPoint(2) = 0

    Dim ptOverrideCenter(2) As Double
    ptOverrideCenter(0) = -3: ptOverrideCenter(1) = -6: ptOverrideCenter(2) = 0
    
    Dim ptJogPoint(2) As Double
    ptJogPoint(0) = 0: ptJogPoint(1) = 5: ptJogPoint(2) = 0

    Dim oDimRadialLarge As AcadDimRadialLarge
    Set oDimRadialLarge = oMS.AddDimRadialLarge(oA.Center, ptChordPoint, ptOverrideCenter, ptJogPoint, PI / 4)

    Dim ptTextPosition(2) As Double
    ptTextPosition(0) = 0: ptTextPosition(1) = 6: ptTextPosition(2) = 0
    oDimRadialLarge.TextPosition = ptTextPosition
    
    Update
    ZoomExtents
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_AddDimRadialLarge()
    ;; This example creates an arc and a jogged arc dimension in model space.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
  
    (setq modelSpace (vla-get-ModelSpace doc))
    
    ;; Define the arc
    (setq center (vlax-3d-point 0 0 0))

    ;; Create the arc in model space
    (setq arc (vla-AddArc modelSpace center 10 (/ PI 3) (/ (* PI 3) 4)))

    ;; Define the jogged arc dimension
    (setq ptChordPoint (vlax-3d-point 0 10 0)
          ptOverrideCenter (vlax-3d-point -3 -6 0)
          ptJogPoint (vlax-3d-point 0 5 0))

    ;; Create the jogged arc dimension in model space
    (setq oDimRadialLarge (vla-AddDimRadialLarge modelSpace center ptChordPoint ptOverrideCenter ptJogPoint (/ PI 4)))

    ;; Set the position of the text for the dimension
    (setq ptTextPosition (vlax-3d-point 0 6 0))
    (vla-put-TextPosition oDimRadialLarge ptTextPosition)
    
    (vla-ZoomExtents acadObj)
)