LoadARX Method (ActiveX)

Loads the specified ObjectARX application.

Supported platforms: Windows only

Signature

VBA:

object.LoadARX Name
object

Type: Application

The object this method applies to.

Name

Access: Input-only

Type: String

The full path name of the .arx application to load.

Return Value (RetVal)

No return value.

Remarks

No additional remarks.

Examples

VBA:

Sub Example_LoadARX()
    ' This example loads an ObjectARX application.
    
    ' Note: The application listed here does not exist and
    ' will cause an error when run. Change the application name
    ' to the path and name of your ObjectARX application.
    ThisDrawing.Application.LoadArx "MyARXApp.arx"
        
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_LoadARX()
    ;; This example loads an ObjectARX application.
    (setq acadObj (vlax-get-acad-object))
    
    ;; Note: The application listed here does not exist and
    ;; will cause an error when run. Change the application name
    ;; to the path and name of your ObjectARX application.
    (vla-LoadArx acadObj "MyARXApp.arx")
)