ObjectModified Event (ActiveX)

Triggered when an object in the drawing has been modified.

Supported platforms: Windows only

Signature

VBA:

object.ObjectModified(Entity)
object

Type: Document

An object expression that evaluates to a valid container object. In this case, the only valid container is a document.

Entity

Type: Document; input to the handler

The object in the drawing that is modified. It can be any one of the drawing objects.

Remarks

This event takes place after the modification operation is complete.

No events will be fired while a modal dialog is being displayed.

Examples

VBA:

Private Sub AcadDocument_ObjectModified(ByVal Object As Object)
    ' This example intercepts a drawing ObjectModified event.
    '
    ' This event is triggered when an object in a drawing is modified.
    '
    ' To trigger this example event: Modify an object in any open drawing

    ' Use the "Object" variable to determine the type of object modified
    MsgBox "A " & TypeName(Object) & " was just modified!"
End Sub

Visual LISP:

Not available