GetWeight Method (ActiveX)

Gets the weight of the control point at a given index.

Supported platforms: Windows only

Signature

VBA:

RetVal = object.GetWeight(Index)
object

Type: Spline

The object this method applies to.

Index

Access: Input-only

Type: Integer

The index location in the array of points that make up the spline. A positive integer beginning with 0.

Return Value (RetVal)

Type: Double

The weight of the specified control point.

Remarks

Control points fine-tune a spline definition by adding weight to a portion of the spline curve.

Examples

VBA:

Sub Example_GetWeight()
    ' This example creates a spline object in model space.
    ' It then finds the weight of the first control point
    ' and changes that value.

    ' Create the spline
    Dim splineObj As AcadSpline
    Dim startTan(0 To 2) As Double
    Dim endTan(0 To 2) As Double
    Dim fitPoints(0 To 8) As Double
    
    startTan(0) = 0.5: startTan(1) = 0.5: startTan(2) = 0
    endTan(0) = 0.5: endTan(1) = 0.5: endTan(2) = 0
    fitPoints(0) = 1: fitPoints(1) = 1: fitPoints(2) = 0
    fitPoints(3) = 5: fitPoints(4) = 5: fitPoints(5) = 0
    fitPoints(6) = 10: fitPoints(7) = 0: fitPoints(8) = 0
    Set splineObj = ThisDrawing.ModelSpace.AddSpline(fitPoints, startTan, endTan)
    ZoomAll
    
    ' Display the coordinates of the first fit point
    Dim weight As Double
    weight = splineObj.GetWeight(0)
    MsgBox "The weight of control point 1 is " & weight, , "GetWeight Example"
    
    ' Change the weight of the first control point
    weight = 5
    splineObj.SetWeight 0, weight
    splineObj.Update
    MsgBox "The weight of control point 1 is now " & weight, , "GetWeight Example"
    
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_GetWeight()
    ;; This example creates a spline object in model space.
    ;; It then finds the weight of the first control point
    ;; and changes that value.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
  
    ;; Create the spline
    (setq startTan (vlax-3d-point 0.5 0.5 0)
          endTan (vlax-3d-point 0.5 0.5 0)
          fitPoints (vlax-make-safearray vlax-vbDouble '(0 . 8)))
    (vlax-safearray-fill fitPoints '(1 1 0
                                     5 5 0
                                     10 0 0
                                    )
    )

    (setq modelSpace (vla-get-ModelSpace doc))
    (setq splineObj (vla-AddSpline modelSpace fitPoints startTan endTan))
    (vla-ZoomAll acadObj)
    
    ;; Display the coordinates of the first fit point
    (setq weight (vla-GetWeight splineObj 0))
    (alert (strcat "The weight of control point 1 is " (rtos weight 2)))
    
    ;; Change the weight of the first control point
    (setq weight 5)
    (vla-SetWeight splineObj 0 weight)
    (vla-Update splineObj)
    (alert (strcat "The weight of control point 1 is now " (rtos weight 2)))
)