PrintFile Property (ActiveX)

Specifies an alternate name to use for the temporary plot file name.

Supported platforms: Windows only

Signature

VBA:

object.PrintFile
object

Type: PreferencesFiles

The object this property applies to.

Property Value

Read-only: No

Type: String

The alternate name for plot files. Enter "." to use default (the current drawing name). Enter the drive, path, and file name for the alternate plot file.

Remarks

The default name is the name of the drawing, plus the file extension .plt.

Examples

VBA:

Sub Example_PrintFile()
    ' This example returns the current setting of
    ' PrintFile. It then changes the value, and finally
    ' it resets the value back to the original setting.
    
    Dim preferences As AcadPreferences
    Dim currPrintFile As String
    Dim newPrintFile As String
    
    Set preferences = ThisDrawing.Application.Preferences
    
    ' Retrieve the current PrintFile value
    currPrintFile = preferences.Files.PrintFile
    MsgBox "The current value for PrintFile is " & currPrintFile, vbInformation, "PrintFile Example"
    
    ' Change the value for PrintFile
    newPrintFile = "TestPrintFile.plt"
    preferences.Files.PrintFile = newPrintFile
    MsgBox "The new value for PrintFile is " & newPrintFile, vbInformation, "PrintFile Example"
    
    ' Reset PrintFile to its original value
    preferences.Files.PrintFile = currPrintFile
    MsgBox "The PrintFile value is reset to " & currPrintFile, vbInformation, "PrintFile Example"
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_PrintFile()
    ;; This example returns the current setting of
    ;; PrintFile. It then changes the value, and finally
    ;; it resets the value back to the original setting.
    (setq acadObj (vlax-get-acad-object))
    (setq preferences (vla-get-Preferences acadObj))
    
    ;; Retrieve the current PrintFile value
    (setq currPrintFile (vla-get-PrintFile (vla-get-Files preferences)))
    (alert (strcat "The current value for PrintFile is " currPrintFile))
    
    ;; Change the value for PrintFile
    (setq newValue "TestPrintFile.plt")
    (vla-put-PrintFile (vla-get-Files preferences) newValue)
    (alert (strcat "The new value for PrintFile is " newValue))
    
    ;; Reset PrintFile to its original value
    (vla-put-PrintFile (vla-get-Files preferences) currPrintFile)
    (alert (strcat "The PrintFile value is reset to " currPrintFile))
)