NumberOfControlPoints Property (ActiveX)

Gets the number of control points of the spline.

Supported platforms: Windows only

Signature

VBA:

object.NumberOfControlPoints 
object

Type: Spline

The object this property applies to.

Property Value

Read-only: Yes

Type: Integer

The number of control points of the spline.

Remarks

Control points fine-tune a spline definition by adding weight to a portion of the spline curve.

You can query the current position of a control point by using the GetControlPoint method. You can set a new coordinate location for a control point by using the SetControlPoint method. You can set a new weight for a control point by using the SetWeight method.

Examples

VBA:

Sub Example_NumberOfControlPoints()
    ' This example creates a spline object in model space.
    ' It then finds the number of control points for that spline.

    ' Create the spline
    Dim splineObj As AcadSpline
    Dim startTan(0 To 2) As Double
    Dim endTan(0 To 2) As Double
    Dim fitPoints(0 To 8) As Double
    
    startTan(0) = 0.5: startTan(1) = 0.5: startTan(2) = 0
    endTan(0) = 0.5: endTan(1) = 0.5: endTan(2) = 0
    fitPoints(0) = 1: fitPoints(1) = 1: fitPoints(2) = 0
    fitPoints(3) = 5: fitPoints(4) = 5: fitPoints(5) = 0
    fitPoints(6) = 10: fitPoints(7) = 0: fitPoints(8) = 0
    Set splineObj = ThisDrawing.ModelSpace.AddSpline(fitPoints, startTan, endTan)
    ZoomAll
    
    MsgBox "The Spline has " & splineObj.NumberOfControlPoints & " control points.", , "NumberOfControlPoints Example"

End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_NumberOfControlPoints()
    ;; This example creates a spline object in model space.
    ;; It then finds the number of control points for that spline.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
  
    ;; Create the spline
    (setq startTan (vlax-3d-point 0.5 0.5 0)
          endTan (vlax-3d-point 0.5 0.5 0)
          fitPoints (vlax-make-safearray vlax-vbDouble '(0 . 8)))
    (vlax-safearray-fill fitPoints '(1 1 0
				     5 5 0
				     10 0 0
				    )
    )

    (setq modelSpace (vla-get-ModelSpace doc))
    (setq splineObj (vla-AddSpline modelSpace fitPoints startTan endTan))
    (vla-ZoomAll acadObj)
    
    (alert (strcat "The Spline has " (itoa (vla-get-NumberOfControlPoints splineObj)) " control points."))
)