GetDataType Method (ActiveX)

Returns the data type and unit type for the specified row type.

Supported platforms: Windows only

Signature

VBA:

object.GetDataType rowType, pDataType, pUnitType
object

Type: Table, TableStyle

The objects this method applies to.

rowType

Access: Input-only

Type: AcRowType enum

The row type.

  • acDataRow
  • acTitleRow
  • acHeaderRow
  • acUnknownRow
pDataType

Access: Output-only

Type: AcValueDataType enum

The data type of the row type.

  • acBuffer
  • acDate
  • acDouble
  • acGeneral
  • acLong
  • acObjectId
  • acPoint2d
  • acPoint3d
  • acResbuf
  • acString
  • acUnknownDataType
pUnitType

Access: Output-only

Type: AcValueUnitType enum

The unit type of the row type.

  • acUnitAngle
  • acUnitArea
  • acUnitDistance
  • acUnitless
  • acUnitVolume

Return Value (RetVal)

No return value.

Remarks

No additional remarks.

Examples

VBA:

Not available

Visual LISP:

Not available