RemoveHiddenLines Property (ActiveX)

Specifies if hidden lines are to be plotted on a paper space viewport. (Obsolete)

Supported platforms: Windows only

Signature

VBA:

object.RemoveHiddenLines
object

Type: PViewport

The object this property applies to.

Property Value

Read-only: No

Type: Boolean

Remarks

This property is obsolete and will be removed in a future version.

Examples

VBA:

Sub Example_RemoveHiddenLines()
    ' This example creates a new paper space viewport.
    ' It then displays the value of RemoveHiddenLines for the viewport.
    
    Dim pviewportObj As AcadPViewport
    Dim center(0 To 2) As Double
    Dim width As Double
    Dim height As Double
    
    ' Define the paper space viewport
    center(0) = 3: center(1) = 3: center(2) = 0
    width = 40
    height = 40
    
    ' Change from model space to paper space
    ThisDrawing.ActiveSpace = acPaperSpace

    ' Create the paper space viewport
    Set pviewportObj = ThisDrawing.PaperSpace.AddPViewport(center, width, height)
    pviewportObj.DISPLAY True
    ThisDrawing.mspace = True
    ThisDrawing.ActivePViewport = pviewportObj
    ThisDrawing.Regen acAllViewports
    
    ' Find the value for RemoveHiddenLines for the viewport
    Dim removeHidden As Boolean
    removeHidden = pviewportObj.RemoveHiddenLines
    MsgBox "The value of the RemoveHiddenLines property for the paperspace viewport is " & pviewportObj.RemoveHiddenLines, , "RemoveHiddenLines Example"

End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_RemoveHiddenLines()
    ;; This example creates a new paper space viewport.
    ;; It then displays the value of ShadePlot for the viewport.
    ;; ShadePlot replaces RemoveHiddenLines.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
    
    ;; Define the paper space viewport
    (setq center (vlax-3d-point 3 3 0)
          width 40
          height 40)
    
    ;; Change from model space to paper space
    (vla-put-ActiveSpace doc acPaperSpace)

    ;; Create the paper space viewport
    (setq paperSpace (vla-get-PaperSpace doc))
    (setq pviewportObj (vla-AddPViewport paperSpace center width height))

    (vla-Display pviewportObj :vlax-true)
    (vla-put-MSpace doc :vlax-true)
    (vla-put-ActivePViewport doc pviewportObj)
    (vla-Regen doc acAllViewports)
    
    ;; Find the value for ShadePlot for the viewport
    (alert (strcat "The value of the ShadePlot property for the paperspace viewport is " (itoa (vla-get-ShadePlot pviewportObj))))
)