Specifies the name of the Big Font file associated with the text or attribute.
Supported platforms: Windows only
Read-only: No
Type: String
The name of the Big Font file.
This property is similar to the FontFile property, except that it is used to specify an Asian-language Big Font file. The only valid file type is SHX.
This property cannot be set to NULL or an empty string.
VBA:
Sub Example_BigFontFile() ' This example returns the current setting of ' BigFontFile. It then changes the value. Dim textStyle1 As AcadTextStyle Dim currBigFontFile As String Dim newBigFontFile As String Set textStyle1 = ThisDrawing.ActiveTextStyle ' Retrieve the current BigFontFile value currBigFontFile = textStyle1.BigFontFile MsgBox "The current value for BigFontFile is " & currBigFontFile, vbInformation, "BigFontFile Example" ' Change the value for BigFontFile newBigFontFile = "C:/AutoCAD/Fonts/bigfont.shx" textStyle1.BigFontFile = newBigFontFile MsgBox "The new value for BigFontFile is " & newBigFontFile, vbInformation, "BigFontFile Example" End Sub
Visual LISP:
(vl-load-com) (defun c:Example_BigFontFile() ;; This example returns the current setting of ;; BigFontFile. It then changes the value. (setq acadObj (vlax-get-acad-object)) (setq doc (vla-get-ActiveDocument acadObj)) (setq textStyle1 (vla-get-ActiveTextStyle doc)) ;; Retrieve the current BigFontFile value (setq currBigFontFile (vla-get-BigFontFile textStyle1)) (alert (if (= currBigFontFile "") (strcat "There is not big font file assigned to this font.") (strcat "The current value for BigFontFile is " currBigFontFile)) ) ;; Change the value for BigFontFile (setq newBigFontFile (findfile "./Fonts/bigfont.shx")) (vla-put-BigFontFile textStyle1 newBigFontFile) (alert (strcat "The new value for BigFontFile is " newBigFontFile)) )