ConfigName Property (ActiveX)

Specifies the plotter configuration name.

Supported platforms: Windows only

Signature

VBA:

object.ConfigName
object

Type: Layout, PlotConfiguration

The objects this property applies to.

Property Value

Read-only: No

Type: String

The name of the PC3 file or print device to be used by the layout or plot configuration.

Remarks

This property does not take a fully qualified path, only the file name for the configuration file. Use the PrinterConfigPath property to specify the path for printer configuration files.

Use the RefreshPlotDeviceInfo method before trying to change the ConfigName property.

Do not assign the ConfigName property a value of "None." Attempting to do so results in unexpected behavior.

Examples

VBA:

Sub Example_ConfigName()
    ' This example will add a new plot configuration to the current drawing.
    ' It will then list the plotter configuration file name for each Layout
    ' in the current drawing, change the configuration for Layout1 to "DWF Classic.pc3"
    ' and re-display the configuration information for the drawing.
    '
    ' * Note: File names may differ on your system, so be prepared to change
    ' the configuration file name used in the example to a file that exists
    ' on your system.

    Dim Layouts As AcadLayouts, Layout As ACADLayout
    Dim msg As String
    Dim ACADPref As AcadPreferencesFiles
    Dim originalValue As Variant
    
    ' Get the files preferences object
    Set ACADPref = ThisDrawing.Application.preferences.Files

    ' Read and display the original value
    originalValue = ACADPref.PrinterConfigPath
    
    ' Get layouts collection from document object
    Set Layouts = ThisDrawing.Layouts
    
    ' Display current plotter configuration information
    GoSub DISPLAY_CONFIG
    
    ' Change plotter configuration file for "Layout1"
    Layouts("Layout1").ConfigName = "DWF6 ePlot.pc3"
    
    ' Display new plotter configuration information
    GoSub DISPLAY_CONFIG
    
    Exit Sub
        
DISPLAY_CONFIG:
    msg = vbCrLf & vbCrLf   ' Start with a space
    
    ' Format and display current directory for configuration files
    msg = msg & vbTab & "Directories that will be scanned for the plotter configuration files are: " _
                & vbCrLf & vbTab & vbTab & originalValue & vbCrLf & vbCrLf
    
    ' Get the plotter configuration name of every layout in this drawing
    For Each Layout In Layouts
        ' Format for display
        msg = msg & vbTab & Layout.name & " is using configuration: " & Layout.ConfigName & vbCrLf
    Next
    
    ' Display paper units information
    MsgBox "The plotter configuration information used in the current drawing is listed below." & msg
    
    Return
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_ConfigName()
    ;; This example will add a new plot configuration to the current drawing.
    ;; It will then list the plotter configuration file name for each Layout
    ;; in the current drawing, change the configuration for Layout1 to "DWF Classic.pc3"
    ;; and re-display the configuration information for the drawing.
    ;;
    ;; * Note: File names may differ on your system, so be prepared to change
    ;; the configuration file name used in the example to a file that exists
    ;; on your system.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
  
    ;; Get the files preferences object
    (setq ACADPref (vla-get-Files (vla-get-Preferences acadObj)))

    ;; Read and display the original value
    (setq originalValue (vla-get-PrinterConfigPath ACADPref))
    
    ;; Get layouts collection from document object
    (setq Layouts (vla-get-Layouts doc))

    ;; Format and display current directory for configuration files
    (setq msg "")
    (setq msg (strcat msg "Directories that will be scanned for the plotter configuration files are: \n"
                          originalValue "\n"))
    
    ;; Get the plotter configuration name of every layout in this drawing
    (vlax-for Layout Layouts
        (setq msg (strcat msg "\n" (vla-get-Name Layout) " is using configuration: " (vla-get-ConfigName Layout)))
    )
    
    ;; Display paper units information
    (alert (strcat "The plotter configuration information used in the current drawing is listed below.\n\n" msg))
    
    ;; Change plotter configuration file for "Layout1"
    (vla-put-ConfigName (vla-Item Layouts "Layout1") "DWF6 ePlot.pc3")
    
    ;; Display new plotter configuration information
    ;; Format and display current directory for configuration files
    (setq msg "")
    (setq msg (strcat msg "Directories that will be scanned for the plotter configuration files are: \n"
                          originalValue "\n"))
    
    ;; Get the plotter configuration name of every layout in this drawing
    (vlax-for Layout Layouts
        (setq msg (strcat msg "\n" (vla-get-Name Layout) " is using configuration: " (vla-get-ConfigName Layout)))
    )
    
    ;; Display paper units information
    (alert (strcat "The plotter configuration information used in the current drawing is listed below.\n\n" msg))
)