Activate Event (ActiveX)

Triggered when a document window is activated.

Supported platforms: Windows only

Signature

VBA:

object.Activate()
object

Type: Document

An object expression that evaluates to a valid container object. In this case, the only valid container is a document.

Remarks

No events will be fired while a modal dialog is being displayed.

Examples

VBA:

Private Sub AcadDocument_Activate()
    ' This example intercepts a drawing Activate event.
    '
    ' This event is triggered when a drawing window becomes active.
    '
    ' To trigger this example event: Either open a new drawing or switch from
    ' one drawing window to another

    MsgBox "You have just activated a drawing!"
End Sub

Visual LISP:

Not available