DefaultPlotStyleForObjects Property (ActiveX)

Specifies the default plot style name for newly created objects.

Supported platforms: Windows only

Signature

VBA:

object.DefaultPlotStyleForObjects
object

Type: PreferencesOutput

The object this property applies to.

Property Value

Read-only: No

Type: String

Valid entries include "ByLayer", "ByBlock", "Normal", or any style name in the currently loaded plot style.

Remarks

The initial value of this property is "ByLayer".

This property is available only when PlotPolicy is set to acPolicyNamed.

Use the DefaultPlotStyleTable property to find the current plot style.

Note: The value of this property is stored in the DEFLPLSTYLE system variable.

Examples

VBA:

Sub Example_DefaultPlotStyleForObjects()
    ' This example reads and modifies the preference value that controls
    ' the default plot style name for newly created objects.
    ' When finished, this example resets the preference value back to
    ' its original value.
    
    Dim ACADPref As AcadPreferencesOutput
    Dim originalPolicyValue As Variant, originalValue As Variant, newValue As Variant
    
    ' Get the output preferences object
    Set ACADPref = ThisDrawing.Application.preferences.Output
    
    ' Set the default plot style to named plot styles
    originalPolicyValue = ACADPref.PlotPolicy
    ACADPref.PlotPolicy = acPolicyNamed
    
    ' Read and display the original value
    originalValue = ACADPref.DefaultPlotStyleForObjects
    MsgBox "The DefaultPlotStyleForObjects preference is: " & originalValue

    ' Toggle and display the DefaultPlotStyleForObjects preference
    If ACADPref.DefaultPlotStyleForObjects = "ByBlock" Then
        ACADPref.DefaultPlotStyleForObjects = "Normal"
    Else
        ACADPref.DefaultPlotStyleForObjects = "ByBlock"
    End If
    
    newValue = ACADPref.DefaultPlotStyleForObjects
    MsgBox "The DefaultPlotStyleForObjects preference has been set to: " & newValue

    ' Reset the preference back to its original value
    '
    ' * Note: Comment out this last section to leave the change to
    '         this preference in effect
    ACADPref.DefaultPlotStyleForObjects = originalValue
    MsgBox "The DefaultPlotStyleForObjects preference was reset back to: " & originalValue
    
    ACADPref.PlotPolicy = originalPolicyValue
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_DefaultPlotStyleForObjects()
    ;; This example reads and modifies the preference value that controls
    ;; the default plot style name for newly created objects.
    ;; When finished, this example resets the preference value back to
    ;; its original value.
    (setq acadObj (vlax-get-acad-object))
    (setq preferences (vla-get-Preferences acadObj))
    
    ;; Get the output preferences object
    (setq ACADPref (vla-get-Output preferences))
    
    ;; Set the default plot style to named plot styles
    (setq originalPolicyValue (vla-get-PlotPolicy ACADPref))
    (vla-put-PlotPolicy ACADPref acPolicyNamed)

    ;; Read and display the original value
    (setq originalValue (vla-get-DefaultPlotStyleForObjects ACADPref))
    (alert (strcat "The DefaultPlotStyleForObjects preference is: " originalValue))

    ;; Toggle and display the DefaultPlotStyleForObjects preference
    (if (= (vla-get-DefaultPlotStyleForObjects ACADPref) "ByBlock")
        (vla-put-DefaultPlotStyleForObjects ACADPref "Normal")
        (vla-put-DefaultPlotStyleForObjects ACADPref "ByBlock")
    )
    
    (setq newValue (vla-get-DefaultPlotStyleForObjects ACADPref))
    (alert (strcat "The DefaultPlotStyleForObjects preference has been set to: " newValue))

    ;; Reset the preference back to its original value
    ;;
    ;; * Note: Comment out this last section to leave the change to
    ;;         this preference in effect
    (vla-put-DefaultPlotStyleForObjects ACADPref originalValue)
    (alert (strcat "The DefaultPlotStyleForObjects preference was reset back to: " originalValue))

    (vla-put-PlotPolicy ACADPref originalPolicyValue)
)