BeginRightClick Event (ActiveX)

Triggered after the user right-clicks on the drawing window.

Supported platforms: Windows only

Signature

VBA:

object.BeginRightClick(PickPoint)
object

Type: Document

An object expression that evaluates to a valid container object. In this case, the only valid container is a document.

PickPoint

Type: Variant (three-element array of doubles); input to the handler

The 3D WCS coordinate that was right-clicked.

Remarks

No events will be fired while a modal dialog is being displayed.

Examples

VBA:

Private Sub AcadDocument_BeginRightClick(ByVal PickPoint As Variant)
    ' This example intercepts a drawing BeginRightClick event.
    '
    ' This event is triggered when a drawing receives
    ' a right mouse click in its working area.
    '
    ' To trigger this example event: Position the cursor over the working area of
    ' a drawing window and click the right mouse button.

    ' Use the "PickPoint" variable to determine where on the drawing the user clicked
    MsgBox "A drawing has just been right-clicked at:" & vbCrLf & _
            PickPoint(0) & vbCrLf & _
            PickPoint(1) & vbCrLf & _
            PickPoint(2)

End Sub

Visual LISP:

Not available