BeginShortcutMenuGrip Event (ActiveX)

Triggered after the user right-clicks on the drawing window, and before the shortcut menu appears in grip mode.

Supported platforms: Windows only

Signature

VBA:

object.BeginShortcutMenuGrip(ShortcutMenu)
object

Type: Document

An object expression that evaluates to a valid container object. In this case, the only valid container is a document.

ShortcutMenu

Type: PopupMenu object; input/output from the handler

The shortcut menu about to be displayed.

Remarks

This event allows you to make changes to the shortcut menu before it is displayed. To make changes to the shortcut menu, edit the PopupMenu object that is passed in to your handler from the event. This same PopupMenu object is passed out as the current shortcut menu. Use the EndShortcutMenu event to perform any cleanup work on the shortcut menu.

There is a hot grip active when this event is triggered.

This event is triggered after all shortcut menu elements, including any ObjectARX command additions, have occurred.

No events will be fired while a modal dialog is being displayed.

Examples

VBA:

Private Sub AcadDocument_BeginShortcutMenuGrip(ShortcutMenu As AutoCAD.IAcadPopupMenu)
    ' This example intercepts a shortcut menu start while you are in the grip mode.
    '
    MsgBox "You have just initiated a shortcut menu in grip mode!"
End Sub

Visual LISP:

Not available