Database Property (ActiveX)

Gets the database in which the object belongs.

Supported platforms: Windows only

Signature

VBA:

object.Database
object

Type: Document

The object this property applies to.

Property Value

Read-only: Yes

Type: Database

The Database object that contains the object.

Remarks

No additional remarks.

Examples

VBA:

Sub Example_Database()
    ' This example references the Database object obtained from model space.
    ' Information from the Database object is then displayed
    
    Dim Database As AcadDatabase
    
    ' Attach to Database object
    Set Database = ThisDrawing.ModelSpace.Database
    MsgBox "We now have access to the properties and methods of the Database object!"
    
    ' Retrieve the number of Blocks in this database
    MsgBox "The number of Blocks in this database is: " & Database.Blocks.Count

    ' Release object
    Set Database = Nothing
    MsgBox "The Database object has been released!"
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_Database()
    ;; This example references the Database object obtained from model space.
    ;; Information from the Database object is then displayed
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
    
    ;; Attach to Database object
    (setq database (vla-get-Database (vla-get-ModelSpace doc)))
    (alert "We now have access to the properties and methods of the Database object!")
    
    ;; Retrieve the number of Blocks in this database
    (alert (strcat "The number of Blocks in this database is: " (itoa (vla-get-Count (vla-get-Blocks database)))))

    ;; Release object
    (vlax-release-object database)
    (alert "The Database object has been released!")
)