WorkspacePath Property (ActiveX)

Specifies the path for the database workspace file.

Supported platforms: Windows only

Signature

VBA:

object.WorkspacePath
object

Type: PreferencesFiles

The object this property applies to.

Property Value

Read-only: No

Type: String

The drive, path, and file name of the database workspace file.

Remarks

No additional remarks.

Examples

VBA:

Sub Example_WorkspacePath()
    ' This example reads and modifies the preference value that controls
    ' the path for the database workspace file.
    ' When finished, this example resets the preference value back to
    ' its original value.
    
    Dim ACADPref As AcadPreferencesFiles
    Dim originalValue As Variant, newValue As Variant
    
    ' Get the files preferences object
    Set ACADPref = ThisDrawing.Application.preferences.Files
    
    ' Read and display the original value
    originalValue = ACADPref.WorkspacePath
    MsgBox "The WorkspacePath preference is set to: " & originalValue

    ' Modify the WorkspacePath preference by changing the path to "C:\"
    ACADPref.WorkspacePath = "C:\"
    newValue = ACADPref.WorkspacePath
    MsgBox "The WorkspacePath preference has been set to: " & newValue

    ' Reset the preference back to its original value
    '
    ' * Note: Comment out this last section to leave the change to
    '         this preference in effect
    ACADPref.WorkspacePath = originalValue
    MsgBox "The WorkspacePath preference was reset back to: " & originalValue
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_WorkspacePath()
    ;; This example reads and modifies the preference value that controls
    ;; the path for the database workspace file.
    ;; When finished, this example resets the preference value back to
    ;; its original value.
    (setq acadObj (vlax-get-acad-object))
  
    ;; Get the files preferences object
    (setq ACADPref (vla-get-Files (vla-get-Preferences acadObj)))
    
    ;; Read and display the original value
    (setq originalValue (vla-get-WorkspacePath ACADPref))
    (alert (strcat "The WorkspacePath preference is set to: " originalValue))

    ;; Modify the WorkspacePath preference by changing the path to "C:\\"
    (vla-put-WorkspacePath ACADPref "C:\\")
    (alert (strcat "The WorkspacePath preference has been set to: " (vla-get-WorkspacePath ACADPref)))

    ;; Reset the preference back to its original value
    ;;
    ;; * Note: Comment out this last section to leave the change to
    ;;         this preference in effect
    (vla-put-WorkspacePath ACADPref originalValue)
    (alert (strcat "The WorkspacePath preference was reset back to: " (vla-get-WorkspacePath ACADPref)))
)