DefaultPlotToFilePath Property (ActiveX)

Specifies the default path for plotting to a file.

Supported platforms: Windows only

Signature

VBA:

object.DefaultPlotToFilePath
object

Type: PreferencesOutput

The object this property applies to.

Property Value

Read-only: No

Type: String

The default path for plotting to a file.

Remarks

This property is equivalent to the AutoCAD Options dialog box setting "Default Location for Plot to File Operations."

Examples

VBA:

Sub Example_DefaultPlotToFilePath()
    ' Note: Change the path to a valid folder on your system.
    
    Dim MyPreference As AcadPreferencesOutput
    Set MyPreference = AcadApplication.preferences.Output
    MyPreference.DefaultPlotToFilePath = "C:\Plots"
    
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_DefaultPlotToFilePath()
    ;; Note: Change the path to a valid folder on your system.
    (setq acadObj (vlax-get-acad-object))
    (setq preferences (vla-get-Preferences acadObj))
  
    (setq MyPreference (vla-get-Output preferences))
    (vla-put-DefaultPlotToFilePath MyPreference "C:\\Plots")
)