Specifies the path for the template files used by the start-up wizards.
Supported platforms: Windows only
VBA:
object.TemplateDWGPath
Type: PreferencesFiles
The object this property applies to.
Read-only: No
Type: String
The drive and path for the template files.
No additional remarks.
VBA:
Sub Example_TemplateDWGPath() ' This example returns the current setting of ' TemplateDWGPath. It then changes the value, and finally ' it resets the value back to the original setting. Dim preferences As AcadPreferences Dim currTemplateDWGPath As String Dim newTemplateDWGPath As String Set preferences = ThisDrawing.Application.preferences ' Retrieve the current TemplateDWGPath value currTemplateDWGPath = preferences.Files.TemplateDwgPath MsgBox "The current value for TemplateDWGPath is " & currTemplateDWGPath, vbInformation, "TemplateDWGPath Example" ' Change the value for TemplateDWGPath newTemplateDWGPath = "TestTemplateDWGPath" preferences.Files.TemplateDwgPath = newTemplateDWGPath MsgBox "The new value for TemplateDWGPath is " & newTemplateDWGPath, vbInformation, "TemplateDWGPath Example" ' Reset TemplateDWGPath to its original value preferences.Files.TemplateDwgPath = currTemplateDWGPath MsgBox "The TemplateDWGPath value is reset to " & currTemplateDWGPath, vbInformation, "TemplateDWGPath Example" End Sub
Visual LISP:
(vl-load-com) (defun c:Example_TemplateDwgPath() ;; This example returns the current setting of ;; TemplateDwgPath. It then changes the value, and finally ;; it resets the value back to the original setting. (setq acadObj (vlax-get-acad-object)) (setq preferences (vla-get-Preferences acadObj)) ;; Retrieve the current TemplateDWGPath value (setq currTemplateDWGPath (vla-get-TemplateDwgPath (vla-get-Files preferences))) (alert (strcat "The current value for TemplateDwgPath is " currTemplateDWGPath)) ;; Change the value for TemplateDWGPath (setq newTemplateDWGPath "TestTemplateDWGPath") (vla-put-TemplateDwgPath (vla-get-Files preferences) newTemplateDWGPath) (alert (strcat "The new value for TemplateDwgPath is " newTemplateDWGPath)) ;; Reset TemplateDWGPath to its original value (vla-put-TemplateDwgPath (vla-get-Files preferences) currTemplateDWGPath) (alert (strcat "The TemplateDwgPath value is reset to " currTemplateDWGPath)) )