PrinterConfigPath Property (ActiveX)

Specifies the location for printer configuration files.

Supported platforms: Windows only

Signature

VBA:

object.PrinterConfigPath
object

Type: PreferencesFiles

The object this property applies to.

Property Value

Read-only: No

Type: String

The drive and path for printer configuration files.

Remarks

No additional remarks.

Examples

VBA:

Sub Example_PrinterConfigPath()
    ' This example reads and modifies the preference value that controls
    ' the location for printer configuration files.
    ' When finished, this example resets the preference value back to
    ' its original value.
    
    Dim ACADPref As AcadPreferencesFiles
    Dim originalValue As Variant, newValue As Variant
    
    ' Get the files preferences object
    Set ACADPref = ThisDrawing.Application.Preferences.Files
    
    ' Read and display the original value
    originalValue = ACADPref.PrinterConfigPath
    MsgBox "The PrinterConfigPath preference is set to: " & originalValue

    ' Modify the PrinterConfigPath preference by changing the path to "C:\"
    ACADPref.PrinterConfigPath = "C:\"
    newValue = ACADPref.PrinterConfigPath
    MsgBox "The PrinterConfigPath preference has been set to: " & newValue

    ' Reset the preference back to its original value
    '
    ' * Note: Comment out this last section to leave the change to
    '         this preference in effect
    ACADPref.PrinterConfigPath = originalValue
    MsgBox "The PrinterConfigPath preference was reset back to: " & originalValue
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_PrinterConfigPath()
    ;; This example reads and modifies the preference value that controls
    ;; the location for printer configuration files.
    ;; When finished, this example resets the preference value back to
    ;; its original value.
    (setq acadObj (vlax-get-acad-object))
    (setq preferences (vla-get-Preferences acadObj))
    
    ;; Read and display the original value
    (setq originalValue (vla-get-PrinterConfigPath (vla-get-Files preferences)))
    (alert (strcat "The PrinterConfigPath preference is set to: " originalValue))

    ;; Modify the PrinterConfigPath preference by changing the path to "C:\\"
    (vla-put-PrinterConfigPath (vla-get-Files preferences) "C:\\")
    (setq newValue (vla-get-PrinterConfigPath (vla-get-Files preferences)))
    (alert (strcat "The PrinterConfigPath preference has been set to: " newValue))

    ;; Reset the preference back to its original value
    ;;
    ;; * Note: Comment out this last section to leave the change to
    ;;         this preference in effect
    (vla-put-PrinterConfigPath (vla-get-Files preferences) originalValue)
    (alert (strcat "The PrinterConfigPath preference was reset back to: " originalValue))
)