LocaleID Property (ActiveX)

Gets the locale ID of the current AutoCAD session.

Supported platforms: Windows only

Signature

VBA:

object.LocaleID
object

Type: Application

The object this property applies to.

Property Value

Read-only: Yes

Type: Long

The locale ID of the current AutoCAD session.

Remarks

The locale ID is defined by the operating system.

Examples

VBA:

Sub Example_LocaleID()
    ' This code retrieves the Locale ID and displays it in a message box
    MsgBox "The locale ID is " & ThisDrawing.Application.LocaleId, , "LocaleID Example"
    
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_LocaleId()
    ;; This code retrieves the Locale ID and displays it in a message box
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))

    (alert (strcat "The locale ID is " (itoa (vla-get-LocaleId acadObj))))
)