FitTolerance Property (ActiveX)

Refits the spline to the existing points with new tolerance values.

Supported platforms: Windows only

Signature

VBA:

object.FitTolerance
object

Type: Spline

The object this property applies to.

Property Value

Read-only: No

Type: Double

The fit tolerance cannot be a negative number.

Remarks

If the fit tolerance is set to zero, then the spline will pass through all the fit points. Providing a value greater than zero allows the curve to pass through the fit points within the specified tolerance.

Examples

VBA:

Sub Example_FitTolerance()
    ' This example creates a spline object in model space.
    ' It then changes the FitTolerance property of that spline.

    ' Create the spline
    Dim splineObj As AcadSpline
    Dim startTan(0 To 2) As Double
    Dim endTan(0 To 2) As Double
    Dim fitPoints(0 To 8) As Double
    
    startTan(0) = 0.5: startTan(1) = 0.5: startTan(2) = 0
    endTan(0) = 0.5: endTan(1) = 0.5: endTan(2) = 0
    fitPoints(0) = 1: fitPoints(1) = 1: fitPoints(2) = 0
    fitPoints(3) = 5: fitPoints(4) = 5: fitPoints(5) = 0
    fitPoints(6) = 10: fitPoints(7) = 0: fitPoints(8) = 0
    Set splineObj = ThisDrawing.ModelSpace.AddSpline(fitPoints, startTan, endTan)
    ZoomAll
    
    ' Find the current FitTolerance value
    Dim currFitTolerance As Double
    currFitTolerance = splineObj.FitTolerance
    MsgBox "The current FitTolerance is " & currFitTolerance, vbInformation, "FitTolerance Example"

    ' Change the fit tolerance value
    splineObj.FitTolerance = 5
    ZoomAll
    MsgBox "The FitTolerance is now " & splineObj.FitTolerance, vbInformation, "FitTolerance Example"

End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_FitTolerance()
    ;; This example creates a spline object in model space.
    ;; It then changes the FitTolerance property of that spline.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
  
    ;; Create the spline
    (setq startTan (vlax-3d-point 0.5 0.5 0)
          endTan (vlax-3d-point 0.5 0.5 0)
          fitPoints (vlax-make-safearray vlax-vbDouble '(0 . 8)))
    (vlax-safearray-fill fitPoints '(1 1 0
				     5 5 0
				     10 0 0
				    )
    )
  
    ;; Create new Spline object
    (setq modelSpace (vla-get-ModelSpace doc))
    (setq splineObj (vla-AddSpline modelSpace fitPoints startTan endTan))
    (vla-ZoomAll acadObj)
    
    ;; Find the current FitTolerance value
    (setq currFitTolerance (vla-get-FitTolerance splineObj))
    (alert (strcat "The current FitTolerance is " (rtos currFitTolerance 2)))

    ;; Change the fit tolerance value
    (vla-put-FitTolerance splineObj 5)
    (vla-ZoomAll acadObj)
    (alert (strcat "The FitTolerance is now " (rtos (vla-get-FitTolerance splineObj) 2)))
)