Toggles the display of the paper background shadow in layouts.
Supported platforms: Windows only
VBA:
object.LayoutDisplayPaperShadow
Type: PreferencesDisplay
The object this property applies to.
Read-only: No
Type: Boolean
The initial value for this property is True.
VBA:
Sub Example_LayoutDisplayPaperShadow() ' This example reads and modifies the preference value that controls ' the display of the paper background shadow in layouts. When finished, this example ' resets the preference value back to its original value. Dim ACADPref As AcadPreferencesDisplay Dim originalValue As Variant, newValue As Variant ' Get the display preferences object Set ACADPref = ThisDrawing.Application.preferences.DISPLAY ' Switch to paper space to view this change ThisDrawing.ActiveSpace = acPaperSpace ' Read and display the original value originalValue = ACADPref.LayoutDisplayPaperShadow MsgBox "The LayoutDisplayPaperShadow preference is set to: " & originalValue ' Modify the LayoutDisplayPaperShadow preference by toggling the value ACADPref.LayoutDisplayPaperShadow = Not (originalValue) newValue = ACADPref.LayoutDisplayPaperShadow ThisDrawing.Regen acAllViewports MsgBox "The LayoutDisplayPaperShadow preference has been set to: " & newValue ' Reset the preference back to its original value ' ' * Note: Comment out this last section to leave the change to ' this preference in effect ACADPref.LayoutDisplayPaperShadow = originalValue ThisDrawing.Regen acAllViewports MsgBox "The LayoutDisplayPaperShadow preference was reset back to: " & originalValue End Sub
Visual LISP:
(vl-load-com) (defun c:Example_LayoutDisplayPaperShadow() ;; This example reads and modifies the preference value that controls ;; the display of the paper background shadow in layouts. When finished, this example ;; resets the preference value back to its original value. (setq acadObj (vlax-get-acad-object)) (setq preferences (vla-get-Preferences acadObj)) ;; Switch to paper space to view this change (vla-put-ActiveSpace doc acPaperSpace) ;; Read and display the original value (setq originalValue (vla-get-LayoutDisplayPaperShadow (vla-get-Display preferences))) (alert (strcat "The LayoutDisplayPaperShadow preference is set to: " (if (= originalValue :vlax-true) "True" "False"))) ;; Modify the LayoutDisplayPaperShadow preference by toggling the value (vla-put-LayoutDisplayPaperShadow (vla-get-Display preferences) (if (= originalValue :vlax-true) :vlax-false :vlax-true)) (setq newValue (vla-get-LayoutDisplayPaperShadow (vla-get-Display preferences))) (vla-Regen doc acAllViewports) (alert (strcat "The LayoutDisplayPaperShadow preference has been set to: " (if (= newValue :vlax-true) "True" "False"))) ;; Reset the preference back to its original value ;; ;; * Note: Comment out this last section to leave the change to ;; this preference in effect (vla-put-LayoutDisplayPaperShadow (vla-get-Display preferences) originalValue) (vla-Regen doc acAllViewports) (alert (strcat "The LayoutDisplayPaperShadow preference was reset back to: " (if (= originalValue :vlax-true) "True" "False"))) )