DisplayOLEScale Property (ActiveX)

Determines whether the OLE scaling dialog is displayed when OLE objects are inserted into a drawing.

Supported platforms: Windows only

Signature

VBA:

object.DisplayOLEScale
object

Type: PreferencesSystem

The object this property applies to.

Property Value

Read-only: No

Type: Boolean

Remarks

The initial value for this property is True.

Examples

VBA:

Sub Example_DisplayOLEScale()
    ' This example reads and modifies the preference value that controls
    ' whether the OLE scaling dialog is displayed when OLE objects are
    ' inserted into a drawing.
    ' When finished, this example resets the preference value back to
    ' its original value.
    
    Dim ACADPref As AcadPreferencesSystem
    Dim originalValue As Variant, newValue As Variant
    
    ' Get the system preferences object
    Set ACADPref = ThisDrawing.Application.Preferences.System
    
    ' Read and display the original value
    originalValue = ACADPref.DisplayOLEScale
    MsgBox "The DisplayOLEScale preference is set to: " & originalValue

    ' Modify the DisplayOLEScale preference by toggling the value
    ACADPref.DisplayOLEScale = Not (ACADPref.DisplayOLEScale)
    newValue = ACADPref.DisplayOLEScale
    MsgBox "The DisplayOLEScale preference has been set to: " & newValue

    ' Reset the preference back to its original value
    '
    ' * Note: Comment out this last section to leave the change to
    '         this preference in effect
    ACADPref.DisplayOLEScale = originalValue
    MsgBox "The DisplayOLEScale preference was reset back to: " & originalValue
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_DisplayOLEScale()
    ;; This example reads and modifies the preference value that controls
    ;; whether the OLE scaling dialog is displayed when OLE objects are
    ;; inserted into a drawing.
    ;; When finished, this example resets the preference value back to
    ;; its original value.
    (setq acadObj (vlax-get-acad-object))
    (setq preferences (vla-get-Preferences acadObj))
    
    ;; Get the system preferences object
    (setq ACADPref (vla-get-System preferences))
    
    ;; Read and display the original value
    (setq originalValue (vla-get-DisplayOLEScale ACADPref))
    (alert (strcat "The DisplayOLEScale preference is set to: " (if (= originalValue :vlax-true) "True" "False")))

    ;; Modify the DisplayOLEScale preference by toggling the value
    (vla-put-DisplayOLEScale ACADPref (if (= originalValue :vlax-true) :vlax-false :vlax-true))
    (setq newValue (vla-get-DisplayOLEScale ACADPref))
    (alert (strcat "The DisplayOLEScale preference has been set to: " (if (= newValue :vlax-true) "True" "False")))

    ;; Reset the preference back to its original value
    ;;
    ;; * Note: Comment out this last section to leave the change to
    ;;         this preference in effect
    (vla-put-DisplayOLEScale ACADPref originalValue)
    (alert (strcat "The DisplayOLEScale preference was reset back to: " (if (= originalValue :vlax-true) "True" "False")))
)