RadiusRatio Property (ActiveX)

Specifies the major to minor axis ratio of an ellipse.

Supported platforms: Windows only

Signature

VBA:

object.RadiusRatio
object

Type: Ellipse

The object this property applies to.

Property Value

Read-only: No

Type: Double

The radius ratio of the arc or circle.

Remarks

If the minor axis is entered longer than the major axis, the ellipse will be round because the radius ratio cannot be greater than 1.0. (A radius ratio of 1.0 defines a circle.)

Radius ratio = 0.25



Radius ratio = 0.75

Examples

VBA:

Sub Example_RadiusRatio()
    ' This example creates an ellipse and finds the radius ratio
    ' for that ellipse. It then changes the radius ratio to 0.75.
    Dim ellObj As AcadEllipse
    Dim majAxis(0 To 2) As Double
    Dim center(0 To 2) As Double
    Dim radRatio As Double
    
    ' Create an ellipse in model space
    center(0) = 5#: center(1) = 5#: center(2) = 0#
    majAxis(0) = 10: majAxis(1) = 20#: majAxis(2) = 0#
    radRatio = 0.3
    Set ellObj = ThisDrawing.ModelSpace.AddEllipse(center, majAxis, radRatio)
    ZoomAll
    MsgBox "This ellipse has a radius ratio of " & ellObj.RadiusRatio, vbInformation, "RadiusRatio Example"

    ' Change the radius ratio of the ellipse
    radRatio = 0.75
    ellObj.RadiusRatio = radRatio
    ellObj.Update
    MsgBox "The ellipse has been udpated with the radius ratio of " & ellObj.RadiusRatio, vbInformation, "RadiusRatio Example"
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_RadiusRatio()
    ;; This example creates an ellipse and finds the radius ratio
    ;; for that ellipse. It then changes the radius ratio to 0.75.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))

    ;; Create an ellipse in model space
    (setq center (vlax-3d-point 5 5 0)
          majAxis (vlax-3d-point 10 20 0)
          radRatio 0.3)
  
    (setq modelSpace (vla-get-ModelSpace doc))
    (setq ellObj (vla-AddEllipse modelSpace center majAxis radRatio))
    (vla-ZoomAll acadObj)

    (alert (strcat "This ellipse has a radius ratio of " (rtos (vla-get-RadiusRatio ellObj) 2)))

    ;; Change the radius ratio of the ellipse
    (vla-put-RadiusRatio ellObj 0.75)
    (vla-Update ellObj)
    (alert (strcat "The ellipse has been udpated with the radius ratio of " (rtos (vla-get-RadiusRatio ellObj) 2)))
)