ShadePlot Property (ActiveX)

Specifies the shaded viewport plotting mode of a viewport.

Supported platforms: Windows only

Signature

VBA:

object.ShadePlot
object

Type: PViewport

The object this property applies to.

Property Value

Read-only: No

Type: AcShadePlot enum

Remarks

No additional remarks.

Examples

VBA:

Sub Example_ShadePlot()
    ' This example creates a paper space viewport,
    ' makes it active, and then sets it to plot as displayed.
    
    Dim newPViewport As AcadPViewport
    Dim centerPoint(0 To 2) As Double
    Dim height As Double
    Dim width As Double
    height = 30#
    width = 40#
    centerPoint(0) = 30#: centerPoint(1) = 30#: centerPoint(2) = 0#
    
    ' Create a paper space Viewport object
    ThisDrawing.ActiveSpace = acPaperSpace
    Set newPViewport = ThisDrawing.PaperSpace.AddPViewport(centerPoint, width, height)
    ZoomAll
    newPViewport.Display True
    ThisDrawing.MSpace = True

    ' Set the viewport to plot as displayed
    ThisDrawing.ActivePViewport = newPViewport
    newPViewport.ShadePlot = acShadePlotAsDisplayed
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_ShadePlot()
    ;; This example creates a paper space viewport,
    ;; makes it active, and then sets it to plot as displayed.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))

    (setq centerPoint (vlax-3d-point 30 30 0)
          width 40
          height 40)
    
    ;; Create a paper space Viewport object
    (vla-put-ActiveSpace doc acPaperSpace)

    (setq paperSpace (vla-get-PaperSpace doc))
    (setq newPViewport (vla-AddPViewport paperSpace centerPoint width height))

    (vla-ZoomAll acadObj)
    (vla-Display newPViewport :vlax-true)
    (vla-put-MSpace doc :vlax-true)

    ;; Set the viewport to plot as displayed
    (vla-put-ActivePViewport doc newPViewport)
    (vla-put-ShadePlot newPViewport acShadePlotAsDisplayed)
)