PrintSpoolExecutable Property (ActiveX)

Specifies the application to use for print spooling.

Supported platforms: Windows only

Signature

VBA:

object.PrintSpoolExecutable
object

Type: PreferencesFiles

The object this property applies to.

Property Value

Read-only: No

Type: String

The print spooling application.

Remarks

This property contains the drive, path, and application name of the print spooling executable to use with AutoSpool.

Examples

VBA:

Sub Example_PrintSpoolExecutable()
    ' This example returns the current setting of
    ' PrintSpoolExecutable. It then changes the value, and finally
    ' it resets the value back to the original setting.
    
    Dim preferences As AcadPreferences
    Dim currPrintSpoolExecutable As String
    Dim newPrintSpoolExecutable As String
    
    Set preferences = ThisDrawing.Application.Preferences
    
    ' Retrieve the current PrintSpoolExecutable value
    currPrintSpoolExecutable = preferences.Files.PrintSpoolExecutable
    MsgBox "The current value for PrintSpoolExecutable is " & currPrintSpoolExecutable, vbInformation, "PrintSpoolExecutable Example"
    
    ' Change the value for PrintSpoolExecutable
    newPrintSpoolExecutable = "TestPrintSpoolExecutable"
    preferences.Files.PrintSpoolExecutable = newPrintSpoolExecutable
    MsgBox "The new value for PrintSpoolExecutable is " & newPrintSpoolExecutable, vbInformation, "PrintSpoolExecutable Example"
    
    ' Reset PrintSpoolExecutable to its original value
    preferences.Files.PrintSpoolExecutable = currPrintSpoolExecutable
    MsgBox "The PrintSpoolExecutable value is reset to " & currPrintSpoolExecutable, vbInformation, "PrintSpoolExecutable Example"
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_PrintSpoolExecutable()
    ;; This example returns the current setting of
    ;; PrintSpoolExecutable. It then changes the value, and finally
    ;; it resets the value back to the original setting.
    (setq acadObj (vlax-get-acad-object))
    (setq preferences (vla-get-Preferences acadObj))
    
    ;; Retrieve the current PrintSpoolExecutable value
    (setq currPrintSpoolExecutable (vla-get-PrintSpoolExecutable (vla-get-Files preferences)))
    (alert (strcat "The current value for PrintSpoolExecutable is " currPrintSpoolExecutable))
    
    ;; Change the value for PrintSpoolExecutable
    (setq newPrintSpoolExecutable "TestPrintSpoolExecutable")
    (vla-put-PrintSpoolExecutable (vla-get-Files preferences) newPrintSpoolExecutable)
    (alert (strcat "The new value for PrintSpoolExecutable is " newPrintSpoolExecutable))
    
    ;; Reset PrintSpoolExecutable to its original value
    (vla-put-PrintSpoolExecutable (vla-get-Files preferences) currPrintSpoolExecutable)
    (alert (strcat "The PrintSpoolExecutable value is reset to " currPrintSpoolExecutable))
)